hdu4288(线段树)

Coder

Time Limit: 20000/10000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 6407    Accepted Submission(s): 2382


Problem Description
  In mathematics and computer science, an algorithm describes a set of procedures or instructions that define a procedure. The term has become increasing popular since the advent of cheap and reliable computers. Many companies now employ a single coder to write an algorithm that will replace many other employees. An added benefit to the employer is that the coder will also become redundant once their work is done.  1
  You are now the signle coder, and have been assigned a new task writing code, since your boss would like to replace many other employees (and you when you become redundant once your task is complete).
Your code should be able to complete a task to replace these employees who do nothing all day but eating: make the digest sum.
  By saying “digest sum” we study some properties of data. For the sake of simplicity, our data is a set of integers. Your code should give response to following operations:
  1. add x – add the element x to the set;
  2. del x – remove the element x from the set;
  3. sum – find the digest sum of the set. The digest sum should be understood by

  where the set S is written as {a 1, a 2, ... , a k} satisfying a 1 < a 2 < a 3 < ... < a k 
  Can you complete this task (and be then fired)?
------------------------------------------------------------------------------
1 See http://uncyclopedia.wikia.com/wiki/Algorithm
 

Input
  There’re several test cases.
  In each test case, the first line contains one integer N ( 1 <= N <= 10 5 ), the number of operations to process.
  Then following is n lines, each one containing one of three operations: “add x” or “del x” or “sum”.
  You may assume that 1 <= x <= 10 9.
  Please see the sample for detailed format.
  For any “add x” it is guaranteed that x is not currently in the set just before this operation.
  For any “del x” it is guaranteed that x must currently be in the set just before this operation.
  Please process until EOF (End Of File).
 

Output
  For each operation “sum” please print one line containing exactly one integer denoting the digest sum of the current set. Print 0 if the set is empty.
 

Sample Input
  
  
9 add 1 add 2 add 3 add 4 add 5 sum add 6 del 3 sum 6 add 1 add 3 add 5 add 7 add 9 sum
 

Sample Output
  
  
3 4 5
Hint
C++ maybe run faster than G++ in this problem.

思路:使用线段树离线操作,首先先把所有操作都记录下来,把过程中所有添加过得数添加到一个数组里面,先sort,再使用unique函数得到一个严格递增数组。过程中所有的添加删除操作都可以在里面进行。然后离线操作,在线段树中对应数组中要操作的位置,进行添加或删除。关键在于每个节点中的sum[i]数组,它代表这一段区间的数组中模5等于i的数的和。update()函数操作至关重要。

#include <stdio.h>
#include <string.h>
#include <algorithm>
#define L(x) (x << 1)//左儿子
#define R(x) (x << 1 | 1)//右儿子
using namespace std;
const int MAXN=100010;
typedef long long ll;
struct Node
{
	int cnt;
	ll sum[5];
}tree[MAXN << 2];
int dat[MAXN];
int tmp[MAXN];
int n;
char cmd[MAXN][5];

void update(int p){
    for(int i=0;i<5;i++)
    {
    	tree[p].sum[i]=tree[p<<1].sum[i]+tree[p<<1|1].sum[((i-tree[p<<1].cnt)%5+5)%5];
	}
	tree[p].cnt=tree[p<<1].cnt+tree[p<<1|1].cnt;
}

void build(int l,int r,int p){
    tree[p].cnt=0;
    for(int i=0;i<5;i++)tree[p].sum[i]=0;
    if(l == r){
        return;
    }
    int mid = (l + r) >> 1;
    build(l,mid,L(p));  
	build(mid+1,r,R(p));
}

void change(int pos,int l,int r,int p,int v,int flag){
    if(l==pos && r==pos){
        tree[p].cnt+=flag;
        tree[p].sum[0]=v;
        return;
    }
    int mid = (l + r) >> 1;
    if(pos <= mid) change(pos,l,mid,L(p),v,flag);
    else if(mid < pos) change(pos,mid+1,r,R(p),v,flag);
    update(p);
}

int main()
{
	while(~scanf("%d",&n))
	{
		int num=0;
		for(int i=0;i<n;i++)
		{
			scanf("%s",cmd[i]);
			if(cmd[i][0]!='s')
			{
				scanf("%d",&dat[i]);
				tmp[num++]=dat[i];
			}
		}
		sort(tmp,tmp+num);
		int x=unique(tmp,tmp+num)-tmp;
		int p;
		build(1,n,1);
		for(int i=0;i<n;i++)
		{
			if(cmd[i][0]=='s')
			{
				//为了方便所有的下标模5都减了1
				printf("%lld\n",tree[1].sum[2]);   
			}
			else
			{
				p=lower_bound(tmp,tmp+num,dat[i])-tmp;
				if(cmd[i][0]=='a')
					change(p+1,1,n,1,dat[i],1);
				else 
					change(p+1,1,n,1,0,-1);
			}
		}
	}
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值