UVA-11889 Benefit

Recently Yaghoub is playing a new trick to sell some more. When somebody gives him A Tomans, he who never has appropriate changes, asks for B Tomans such that lowest common multiple of A and B equals to C and he will pay back a round bill. Or otherwise take some snack instead of the remaining of his money. He believes that finding such a number is hard enough that dissuades students from paying that.
You should write a program that help poor students giving the appropriate amount of money to Yaghoub. Of course if there are several answers you go for students’ benefit which is the lowest of them.

Input
The first line begin with an integer T (T ≤ 100000), the number of tests. Each test that comes in a separate line contains two integers A and C (1 ≤ A,C ≤ 107).

Output
Print the lowest integer B such that LCM(A,B) = C in a single line. If no such integer exists, print ‘NO SOLUTION’ instead. (Quotes for clarity)

Sample Input
3
2 6
32 1760
7 16

Sample Output
3
55
NO SOLUTION

分析: 已知a,c,求最小的b,使lcm(a,b)=c。
若c%a!=0,则无解;否则,b=c/a,若gcd(a,b)=1,则a,b互素,符合题意,若gcd(a,b)!=1,则lcm(a,b)小于c。
要使gcd(a,b)=1,需让b乘上a和b的公共因子,a除以a和b的公共因子,重复上述步骤,直到gcd(a,b)=1。

Source:

#include<stdio.h>
int gcd(int a,int b)
{
    if(b)
        return gcd(b,a%b);
    else
        return a;
}
int main()
{
    int t,a,b,c,g,temp;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d",&a,&c);
        if(c%a)
            printf("NO SOLUTION\n");
        else
        {
            b=c/a;
            temp=1;
            g=gcd(a,b);
            while(g!=1)
            {
                temp*=g;
                a/=g;
                g=gcd(a,b);
            }
            printf("%d\n",b*temp);
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值