HDU1004(STL-map)

3 篇文章 0 订阅
3 篇文章 0 订阅
B - STL之<map>
Time Limit:1000MS    Memory Limit:32768KB    64bit IO Format:%I64d & %I64u

Description

Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result.

This year, they decide to leave this lovely job to you.
 

Input

Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters.

A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output

For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input

    
    
5 green red blue red red 3 pink orange pink 0
 

Sample Output

    
    
red pink
  题意:给出气球的颜色,输出颜色最大的气球。
 分析:
 (1)输入字符串,每种分别计数(strcmp),输出最大对应的字符串。
<span style="font-size:18px;">#include<iostream>
#include<cstring>
using namespace std;
int main()
{
    int n,k[1000];
    char a[1000][100];
    while(cin>>n,n)
    {
        int i,j,t;
        for(i=0; i<n; i++)cin>>a[i];
        for(i=0; i<n; i++)
        {
            t=0;
            for(j=0; j<n; j++)
                if(strcmp(a[i],a[j])==0)
                    k[i]=t++;
        }
        t=0;
        for(i=0; i<n; i++)
            if(k[i]>k[t])
                t=i;
        cout<<a[t]<<endl;
    }
    return 0;
}</span>
 (2)使用STL——<map>
   map中有一一映射的关系,建立color和count之间的关系即map<string,int>ball;

     it->first是map中第一个元素,it->second是map中第二个元素
#include <iostream>
#include <cstdio>
#include <string>
#include <map>
using namespace std;
#define N 102
map<string,int>ball;///颜色和个数的映射
map<string,int>::iterator it;
int main()
{
	int n;
	string color;
	while(scanf("%d",&n),n)
    {
        ball.clear();///先清0
        for(int i=0;i<n;i++)
        {
            cin>>color;
            ball[color]++;
        }
        int max=-1;
        for(it=ball.begin();it!=ball.end();it++)///map
        {
            if(it->second>max){
                color=it->first;
                max=it->second;
            }
        }
        cout<<color<<endl;
    }
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值