02-线性结构3 Pop Sequence

Given a stack which can keep MM numbers at most. Push NN numbers in the order of 1, 2, 3, …, NN and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if MM is 5 and NN is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.
Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): MM (the maximum capacity of the stack), NN (the length of push sequence), and KK (the number of pop sequences to be checked). Then KK lines follow, each contains a pop sequence of NN numbers. All the numbers in a line are separated by a space.
Output Specification:

For each pop sequence, print in one line “YES” if it is indeed a possible pop sequence of the stack, or “NO” if not.
Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2
Sample Output:

YES
NO
NO
YES
NO

问题描述:把1-N个数依次进栈,给出出栈的结果,判断是否可能有这种出栈方式。

思路:当大的数pop出来的时候,小的数肯定已经进去了,所以模拟这一过程,若按照输入的序列不会爆栈,则这种情况是可能的,否则就不可能。

#include <iostream>
#include <stack>

using namespace std;

void input()
{
    int stack_capacity, input_num, input_line;
    stack<int> st;
    cin >> stack_capacity;
    cin >> input_num;
    cin >> input_line;

    int* temp = new int[input_num];
    int* ifpossible = new int[input_line];

    for (int i = 0; i < input_line; i++)
    {
        ifpossible[i] = 1;
        int k = 1;
        for (int j = 0; j<input_num;j++)
        {
            cin >> temp[j];

            while (st.size() <= stack_capacity)
            {
                if (st.empty() || st.top() != temp[j])
                {
                    st.push(k++);
                }
                else if (st.top() == temp[j])
                {
                    st.pop();
                    break;
                }

            }
            if (st.size() > stack_capacity)
            {
                ifpossible[i] = 0;
            }

        }
        while (!st.empty())
            st.pop();

    }

    for (int i = 0; i < input_line; i++)
    {
        if (ifpossible[i] == 0)
            cout << "NO" << endl;
        else
            cout << "YES" << endl;
    }
delete[]temp;
delete[]ifpossible;
}

int main()
{
    input();

    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值