九度OJ-1442:A sequence of numbers

  一道大数据处理的题目。因为数据过大故要注意两点:取模+二分求幂。

  二分求幂就不细说了。取模用到了如下两个公式:

  ①(a*b)%c=((a%c)*(b%c))%c

  ②(a+b)%c=((a%c)+(b%c))%c


题目描述:

Xinlv wrote some sequences on the paper a long time ago, they might be arithmetic or geometric sequences. The numbers are not very clear now, and only the first three numbers of each sequence are recognizable. Xinlv wants to know some numbers in these sequences, and he needs your help.

输入:

The first line contains an integer N, indicting that there are N sequences. Each of the following N lines contain four integers. The first three indicating the first three numbers of the sequence, and the last one is K, indicating that we want to know the K-th numbers of the sequence.

You can assume 0 < K <= 10^9, and the other three numbers are in the range [0, 2^63). All the numbers of the sequences are integers. And the sequences are non-decreasing.

输出:

Output one line for each test case, that is, the K-th number module (%) 200907.

样例输入:
2
1 2 3 5
1 2 4 5
样例输出:
5
16
#include <iostream> 
using namespace std;
long long pow(long long a,long long x);

int main(){
	int n,k;
	long long buf[10];
	long long answer;
	while (cin>>n){
		for (int time=0;time<n;time++){
			//initiate
			//input
			for (int i=0;i<3;i++)
				cin>>buf[i];
			cin>>k;
			if (buf[1]-buf[0]==buf[2]-buf[1])//arithmetic 
				answer=(buf[0]%200907+( (buf[1]-buf[0])%200907 )*( (k-1)%200907 ))%200907;
			else{//geometric 
				answer=(buf[0]%200907*(pow(buf[2]/buf[1],k-1)%200907))%200907;
			}
			cout<<answer<<endl;
		}
	}
	return true;
}
long long pow(long long a,long long x){
	long long pro=1;
	while(x>0){
		if (x%2==1){
			pro*=a;
			pro%=200907;
		}
		x/=2;
		a*=a;
		a%=200907;
	}
	return pro;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值