Euclid's Game

 

Euclid's Game

 1000(ms)

 65535(kb)

 720 / 2828

Starts with two unequal positive numbers (M,N and M>N) on the board. Two players move in turn. On each move, a player has to write on the board a positive number equal to the difference of two numbers already on the board; this number must be new, i.e., different from all the numbers already on the board. The player who cannot move loses the game. Should you choose to move first or second in this game? 

According to the above rules, there are two players play tihs game. Assumptions A write a number on the board at first, then B write it. 

Your task is write a program to judge the winner is A or B.

输入

 

Two unequal positive numbers M and N , M>N (M<1000000)

输出

 

A or B

样例输入

3 1

样例输出

A

 

经过我terrible的英语,终于明白了这道题就是关于欧几里得算法的题目,大概意思就是:

棋盘上以两个不等的正数(M,N和M> N)开始。两名球员依次移动。在每次移动中,玩家必须在棋盘上写上一个正数,该数字等于棋盘上已有的两个数字的差值; 这个数字必须是新的,即与主板上已有的所有数字不同。无法移动的玩家输掉游戏。你应该选择在这场比赛中先手还是后手?
根据以上规则,有两名玩家玩游戏。假设A首先在板上写一个数字,然后B写它。 
你的任务是写一个程序来判断胜利者是A还是B.

每次写的数,只能是最开始两个数的最大公约数的p(p最大为M/gcd(M,N))倍,所以判断M/gcd(M,N)奇偶性即可。

#include<iostream>
using namespace std;
//欧几里得最大公约数 
int gcd(int a, int b) {
	if(b==0) return a;
	return gcd(b,a%b);
}

int main() {
	int m,n,p;
	cin >> m;
	cin >> n;
	p = gcd(m,n);
	//求得最大公约数,如果该A玩家取数/除以最大公约数余2不等于0,则表明该玩家能赢 
	if(( m / p) % 2 != 0)
        cout << "A" << endl;
	else
        cout << "B" << endl;
	return 0;
}

 

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

孤月水明

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值