POJ 1001 Exponentiation 无限大数的指数乘法 题解

POJ做的很好,本题就是要求一个无限位大的指数乘法结果。

要求基础:无限大数位相乘

额外要求:处理特殊情况的能力 -- 关键是考这个能力了。

所以本题的用例特别重要,再聪明的人也会疏忽某些用例的。

本题对程序健壮性的考查到达了变态级别了。

某人贴出的测试用例数据地址: http://poj.org/showmessage?message_id=76017

有了这些用例,几下调试就过了。

我关键漏了的用例:

000.10  1
000000  1
000.00  1
.00000  0
000010  1

#include <stdio.h>
#include <iostream>
#include <string>
#include <vector>
#include <algorithm>
using namespace std;

bool standardizeNumNoDot(string &s)
{
	while (!s.empty() && '0' == s[0]) s.erase(s.begin());
	if (s.empty()) s = "0";//防止n==1的时候,要输出0
	bool notDot = true;
	for (unsigned i = 0; i < s.size() && notDot; i++)
	{
		if ('.' == s[i]) notDot = false;
	}
	if (notDot) return true;

	while (!s.empty() && '0' == s[s.size()-1]) s.erase(s.end()-1);	
	if (!s.empty() && '.' == s[s.size()-1]) s.erase(s.end()-1);
	if ( s.empty() ) s = "0";
	return false;
}

int handleDecimalPoint(string &s)
{
	if (standardizeNumNoDot(s)) return 0;
	int fraction = 0;
	int j = 0;
	for (unsigned i = 0; i < s.size() ; i++)
	{
		if (fraction > 0) fraction++;
		if (s[i] != '.') s[j++] = s[i];
		else fraction++;
	}
	s.erase(s.end()-1);
	return fraction - 1;
}

string mulStr(string a, string b)
{
	if ("0" == a || "0" == b) return "0";
	int ap = handleDecimalPoint(a);
	int bp = handleDecimalPoint(b);

	string ans(a.size()+b.size(), '0');
	for (int i = a.size() - 1; i >= 0 ; i--)
	{
		int carry = 0;
		int an = a[i] - '0';
		for (int j = b.size() - 1; j >= 0 ; j--)
		{
			int bn = b[j] - '0';
			int sum = an * bn + carry + ans[i+j+1] - '0';
			carry = sum / 10;
			ans[i+j+1] = sum % 10 + '0';
		}
		if (carry) ans[i] += carry;
	}
	if (ap > 0 || bp > 0) ans.insert(ans.end() - ap - bp, '.');
	standardizeNumNoDot(ans);
	return ans;
}

string sPow(string s, int n)
{
	if (s.empty() || "0" == s) return "0";//为了程序的健壮性,一定要加上
	if (0 == n) return "1";
	if (1 == n) return s;

	string divideStr = sPow(s, n/2);
	divideStr = mulStr(divideStr, divideStr);
	if (n % 2) divideStr = mulStr(divideStr, s);
	return divideStr;
}

void Exponentiation()
{
	string s;
	int n;
	while(cin>>s>>n)
	{
		standardizeNumNoDot(s);//当n==1的时候
		cout<<sPow(s, n)<<endl;
	}
}

int main()
{
	Exponentiation();
	return 0;
}

本算法用时0MS,哈哈.


  • 4
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Problems involving the computation of exact values of very large magnitude and precision are common. For example, the computation of the national debt is a taxing experience for many computer systems. This problem requires that you write a program to compute the exact value of Rn where R is a real number ( 0.0 < R < 99.999 ) and n is an integer such that 0 < n <= 25. 输入说明 The input will consist of a set of pairs of values for R and n. The R value will occupy columns 1 through 6, and the n value will be in columns 8 and 9. 输出说明 The output will consist of one line for each line of input giving the exact value of R^n. Leading zeros should be suppressed in the output. Insignificant trailing zeros must not be printed. Don't print the decimal point if the result is an integer. 输入样例 95.123 12 0.4321 20 5.1234 15 6.7592 9 98.999 10 1.0100 12 输出样例 548815620517731830194541.899025343415715973535967221869852721 .00000005148554641076956121994511276767154838481760200726351203835429763013462401 43992025569.928573701266488041146654993318703707511666295476720493953024 29448126.764121021618164430206909037173276672 90429072743629540498.107596019456651774561044010001 1.126825030131969720661201 小提示 If you don't know how to determine wheather encounted the end of input: s is a string and n is an integer C++ while(cin>>s>>n) { ... } c while(scanf("%s%d",s,&n)==2) //to see if the scanf read in as many items as you want /*while(scanf(%s%d",s,&n)!=EOF) //this also work */ { ... } 来源 East Central North America 1988 北大OJ平台(代理

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值