FZU 2214 Knapsack problem 01背包变形

 Problem 2214 Knapsack problem

Accept: 410    Submit: 1648
Time Limit: 3000 mSec    Memory Limit : 32768 KB

 Problem Description

Given a set of n items, each with a weight w[i] and a value v[i], determine a way to choose the items into a knapsack so that the total weight is less than or equal to a given limit B and the total value is as large as possible. Find the maximum total value. (Note that each item can be only chosen once).

 Input

The first line contains the integer T indicating to the number of test cases.

For each test case, the first line contains the integers n and B.

Following n lines provide the information of each item.

The i-th line contains the weight w[i] and the value v[i] of the i-th item respectively.

1 <= number of test cases <= 100

1 <= n <= 500

1 <= B, w[i] <= 1000000000

1 <= v[1]+v[2]+...+v[n] <= 5000

All the inputs are integers.

 Output

For each test case, output the maximum value.

 Sample Input

15 1512 42 21 14 101 2

 Sample Output

15

 Source

第六届福建省大学生程序设计竞赛-重现赛(感谢承办方华侨大学)

    题意:题意得普通的01背包题目。

    分析:开始时模板提高了一下,RE。第一次遇到这样的情况,实在没弄清楚问题在哪。后来发现w的值特别大,所以会导致数组溢出。正常的01背包,f[v]指的是容量为v时最大收益。该题需要转化一下思路,从题目中可以看出提示,value的值小于5000。所以该题可以将w和收益两个变量进行互换。普通的01背包f[v]是指在v容量下能得到的最大收益,该题可以转化为f[value]指的是在得到value收益的情况下,需要的最小的w。最终从后向前扫描一遍,找到第一个不大于b的value值即为所求值。见AC代码:

#include<stdio.h>
#include<algorithm>
#define INF 1000000000+10
using namespace std;
const int maxn=5005;
int dp[maxn],w[maxn],v[maxn];
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		int n,b;
		int sum=0;
		scanf("%d%d",&n,&b);
		for(int i=1; i<=n; i++)
		{
			scanf("%d%d",&w[i],&v[i]);
			sum+=v[i];
		}
		for(int i=1; i<=sum; i++)
			dp[i]=INF;
		dp[0]=0;
		for(int i=1; i<=n; i++)
			for(int j=sum; j>=v[i]; j--)
				dp[j]=min(dp[j],dp[j-v[i]]+w[i]);
		int res=0;
		for(int j=sum; j>=0; j--)
			if(dp[j]<=b)
			{
				res=j;
				break;
			}
		printf("%d\n",res);
	}
}
    第一次遇上这样类型的题目,还是刷题太少,见识太浅,唯有多刷题。
    特记下,以备后日回顾。

题意

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值