HDU 5706 GirlCat DFS解决

GirlCat

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 383    Accepted Submission(s): 261


Problem Description
As a cute girl, Kotori likes playing ``Hide and Seek'' with cats particularly.
Under the influence of Kotori, many girls and cats are playing ``Hide and Seek'' together.
Koroti shots a photo. The size of this photo is  n×m , each pixel of the photo is a character of the lowercase(from `a' to `z').
Kotori wants to know how many girls and how many cats are there in the photo.

We define a girl as -- we choose a point as the start, passing by 4 different connected points continuously, and the four characters are exactly ``girl'' in the order.
We define two girls are different if there is at least a point of the two girls are different.
We define a cat as -- we choose a point as the start, passing by 3 different connected points continuously, and the three characters are exactly ``cat'' in the order.
We define two cats are different if there is at least a point of the two cats are different.

Two points are regarded to be connected if and only if they share a common edge.
 

Input
The first line is an integer  T  which represents the case number.

As for each case, the first line are two integers  n  and  m , which are the height and the width of the photo.
Then there are  n  lines followed, and there are  m  characters of each line, which are the the details of the photo.

It is guaranteed that:
T  is about 50.
1n1000 .
1m1000 .
(n×m)2×106 .
 

Output
As for each case, you need to output a single line.
There should be 2 integers in the line with a blank between them representing the number of girls and cats respectively.

Please make sure that there is no extra blank.

 

Sample Input
  
  
3 1 4 girl 2 3 oto cat 3 4 girl hrlt hlca
 

Sample Output
  
  
1 0 0 2 4 1
 

Source
 

Recommend
liuyiding
 


    题意:从输入的字符块中找出连续的"gril""cat"的个数。

    分析:DFS ,BFS都能过。实现保存girl数组和cat数组,DFS过程中迭代结果数组下标即可。比完看题解,甚至暴力if循环都能过……见AC代码:

#include<stdio.h>
#include<string.h>
using namespace std;
const int maxn = 1005;
char girl[4]= {'g','i','r','l'};
char cat[3]= {'c','a','t'};
char map[maxn][maxn];
int vis[maxn][maxn];
int n,m;
int numgirl,numcat;
void dfs(int x,int y,int z)
{
	if(x<0||x>=n||y<0||y>=m||map[x][y]!=girl[z])
		return;
	vis[x][y]=1;
	if(z==3)
	{
		numgirl++;
		return;
	}
	dfs(x+1,y,z+1);
	dfs(x,y+1,z+1);
	dfs(x-1,y,z+1);
	dfs(x,y-1,z+1);
}
void dfs2(int x,int y,int z)
{
	if(x<0||x>=n||y<0||y>=m||map[x][y]!=cat[z])//y> m  不是n
		return;
	vis[x][y]=1;
	if(z==2)
	{
		numcat++;
		return;
	}
	dfs2(x+1,y,z+1);
	dfs2(x,y+1,z+1);
	dfs2(x-1,y,z+1);
	dfs2(x,y-1,z+1);
}
int main()
{
	int T;
	scanf("%d",&T);
	while(T--)
	{
		scanf("%d%d",&n,&m);
		numgirl=0,numcat=0;
		memset(vis,0,sizeof(vis));
		for(int i=0; i<n; i++)
			scanf("%s",map[i]);
		for(int i=0; i<n; i++)
			for(int j=0; j<m; j++)
				if(!vis[i][j])
				{
					if(map[i][j]=='g')
						dfs(i,j,0);
					else if(map[i][j]=='c')
						dfs2(i,j,0);
				}
		printf("%d %d\n",numgirl,numcat);
	}
}
    DFS题还是需要多敲。

    特记下,以备后日回顾。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值