FZU Problem 1304 Recaman’s Sequence

Problem 1304 Recaman’s Sequence

Accept: 699 Submit: 2020 Time Limit: 1000 mSec Memory Limit : 32768 KB

img Problem Description

The Recaman’s sequence is defined by a(0)=0; for m>0, a(m)=a(m-1)-m if the resulting a(m) is positive and not already in the sequence, otherwise a(m)=a(m-1)+m.

The first few numbers in the Recaman’s Sequence is 0, 1, 3, 6, 2, 7, 13, 20, 12, 21, 11, 22, 10, 23, 9, …

Given k, your task is to calculate a(k).

img Input

The input consists of several test cases. Each line of the input contains an integer k where 0<=k<=500000.

The last line contains an integer -1, which should not be processed.

img Output

For each k given in the input, print one line containing a(k) to the output.

img Sample Input

7

10000

-1

img Sample Output

20

18658

img Source

Shanghai2004 Preliminary

解决方案

模拟,注意a(k)的最大值

#include<iostream>
//int MAXN = 0;
int a[500001] = { 0 };
bool visit[3012501] = { 0 }; //a[k]的最大值为3012500
int main() {
	int i;
	for (i = 1; i <= 500000; i++) {
		if (a[i - 1] - i > 0 && !visit[a[i - 1] - i]) {
			a[i] = a[i - 1] - i;
		}
		else a[i] = a[i - 1] + i;
		visit[a[i]] = 1;
		//if (a[i] > MAXN) MAXN = a[i];
	}
	//printf("%d\n", MAXN);
	while (scanf("%d", &i) != EOF) {
		if (i < 0) break;
		printf("%d\n", a[i]);
	}
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值