hiho 1383 The Book List

The Book List
时间限制: 1000ms
单点时限: 1000ms
内存限制: 256MB

描述

The history of Peking University Library is as long as the history of Peking University. It was build in 1898. At the end of year 2015, it had about 11,000 thousand volumes of books, among which 8,000 thousand volumes were paper books and the others were digital ones. Chairman Mao Zedong worked in Peking University Library for a few months as an assistant during 1918 to 1919. He earned 8 Dayang per month there, while the salary of top professors in Peking University is about 280 Dayang per month.

Now Han Meimei just takes the position which Chairman Mao used to be in Peking University Library. Her first job is to rearrange a list of books. Every entry in the list is in the format shown below:

CATEGORY 1/CATEGORY 2/..../CATEGORY n/BOOKNAME

It means that the book BOOKNAME belongs to CATEGORY n, and CATEGORY n belongs to CATEGORY n-1, and CATEGORY n-1 belongs to CATEGORY n-2...... Each book belongs to some categories. Let's call CATEGORY1  "first class category", and CATEGORY 2 "second class category", ...ect. This is an example:

MATH/GRAPH THEORY
ART/HISTORY/JAPANESE HISTORY/JAPANESE ACIENT HISTORY
ART/HISTORY/CHINESE HISTORY/THREE KINDOM/RESEARCHES ON LIUBEI
ART/HISTORY/CHINESE HISTORY/CHINESE MORDEN HISTORY
ART/HISTORY/CHINESE HISTORY/THREE KINDOM/RESEARCHES ON CAOCAO

Han Meimei needs to make a new list on which the relationship between books and the categories is shown by indents. The rules are:

1) The n-th class category has an indent of  4×(n-1) spaces before it.
2) The book directly belongs to the n-th class category has an indent of  4×n spaces before it.
3) The categories and books which directly belong to a category X should be list below X in dictionary order. But all categories go before all books.
4) All first class categories are also list by dictionary order.

For example, the book list above should be changed into the new list shown below:

ART
    HISTORY
        CHINESE HISTORY
            THREE KINDOM
                RESEARCHES ON CAOCAO
                RESEARCHES ON LIUBEI
            CHINESE MORDEN HISTORY
        JAPANESE HISTORY
            JAPANESE ACIENT HISTORY
MATH
    GRAPH THEORY

Please help Han Meimei to write a program to deal with her job.

输入

There are no more than 10 test cases.
Each case is a list of no more than 30 books, ending by a line of "0".
The description of a book contains only uppercase letters, digits, '/' and spaces, and it's no more than 100 characters.
Please note that, a same book may be listed more than once in the original list, but in the new list, each book only can be listed once. If two books have the same name but belong to different categories, they are different books.

输出

For each test case, print "Case n:" first(n starts from 1), then print the new list as required.

样例输入
B/A
B/A
B/B
0
A1/B1/B32/B7
A1/B/B2/B4/C5
A1/B1/B2/B6/C5
A1/B1/B2/B5
A1/B1/B2/B1
A1/B3/B2
A3/B1
A0/A1
0
样例输出
Case 1:
B
    A
    B
Case 2:
A0
    A1
A1
    B
        B2
            B4
                C5
    B1
        B2
            B6
                C5
            B1
            B5
        B32
            B7
    B3
        B2
A3
    B1
题意:就和windows的文件夹和文件之间的关系一样,给出的每一行最后一个是文件,前面都是文件夹,要你先输出文件夹再输出文件,都要按照字典序输出
分析:用结构体+map构建树,由于此题区分了文件夹和文件,所以对于文件我们要特殊处理,用set存就是了
#include<bits/stdc++.h>
using namespace std;
#define maxn 3010
struct node
{
    map<string,int> mp;
    set<string> s;
}p[maxn];
void dfs(int u,int deep)
{
    for(auto &i:p[u].mp)
    {
        int N=4*(deep-1);
        for(int j=1;j<=N;j++) putchar(' ');
        puts(i.first.c_str());
        dfs(i.second,deep+1);
    }
    for(auto &i:p[u].s)
    {
        int N=4*(deep-1);
        for(int j=1;j<=N;j++) putchar(' ');
        puts(i.c_str());
    }
}
int main()
{
    char ch[110],c[110];
    int num=0,cnt;
    int ca=0;
    while(gets(ch))
    {
        int n=strlen(ch);
        if(n==1&&ch[0]=='0')
        {
            printf("Case %d:\n",++ca);
            dfs(0,1);
            num=0;
            for(int i=0;i<maxn;i++) p[i].mp.clear(),p[i].s.clear();
            continue;
        }
        ch[n]='\\';
        ch[n+1]=0;
        cnt=0;
        int k=0;
        string ss;
        for(int i=0;i<=n;i++)
        {
            if(ch[i]=='/')
            {
                c[k]=0;
                ss=c;
                if(p[cnt].mp.find(ss)==p[cnt].mp.end())
                {
                    num++;
                    p[cnt].mp[ss]=num;
                    cnt=num;
                }
                else cnt=p[cnt].mp[ss];
                k=0;
            }
            else if(ch[i]=='\\')
            {
                c[k]=0;
                ss=c;
                p[cnt].s.insert(ss);
                k=0;
            }
            else c[k++]=ch[i];
        }
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值