Generalized Matrioshkas  POJ - 3195 JAVA

92 篇文章 0 订阅
75 篇文章 0 订阅

D - Generalized Matrioshkas

 POJ - 3195 

Vladimir worked for years making matrioshkas, those nesting dolls that certainly represent truly Russian craft. A matrioshka is a doll that may be opened in two halves, so that one finds another doll inside. Then this doll may be opened to find another one inside it. This can be repeated several times, till a final doll – that cannot be opened – is reached.

Recently, Vladimir realized that the idea of nesting dolls might be generalized to nesting toys. Indeed, he has designed toys that contain toys but in a more general sense. One of these toys may be opened in two halves and it may have more than one toy inside it. That is the new feature that Vladimir wants to introduce in his new line of toys.

Vladimir has developed a notation to describe how nesting toys should be constructed. A toy is represented with a positive integer, according to its size. More precisely: if when opening the toy represented by m we find the toys represented by n1, n2, …, nr, it must be true that n1 + n2 + … + nr < m. And if this is the case, we say that toy m contains directly the toys n1, n2, …, nr. It should be clear that toys that may be contained in any of the toys n1, n2, …, nrare not considered as directly contained in the toy m.

generalized matrioshka is denoted with a non-empty sequence of non zero integers of the form:

a1a2aN

such that toy k is represented in the sequence with two integers −k and k, with the negative one occurring in the sequence first that the positive one.

For example, the sequence

−9−7−22−3−2−112379

represents a generalized matrioshka conformed by six toys, namely, 1, 2 (twice), 3, 7 and 9. Note that toy 7 contains directly toys 2 and 3. Note that the first copy of toy 2 occurs left from the second one and that the second copy contains directly a toy 1. It would be wrong to understand that the first −2 and the last 2 should be paired.

On the other hand, the following sequences do not describe generalized matrioshkas:

−9−7−22−3−1−221379

because toy 2 is bigger than toy 1 and cannot be allocated inside it.

−9−7−22−3−2−11237−229

because 7 and 2 may not be allocated together inside 9.

−9−7−22−3−1−232179

because there is a nesting problem within toy 3.

Your problem is to write a program to help Vladimir telling good designs from bad ones.

Input

The input file contains several test cases, each one of them in a separate line. Each test case is a sequence of non zero integers, each one with an absolute value less than 107.

Output

Output texts for each input case are presented in the same order that input is read.

For each test case the answer must be a line of the form

:-) Matrioshka!

if the design describes a generalized matrioshka. In other case, the answer should be of the form

:-( Try again.

Sample Input

-9 -7 -2 2 -3 -2 -1 1 2 3 7 9
-9 -7 -2 2 -3 -1 -2 2 1 3 7 9
-9 -7 -2 2 -3 -1 -2 3 2 1 7 9
-100 -50 -6 6 50 100
-100 -50 -6 6 45 100
-10 -5 -2 2 5 -4 -3 3 4 10
-9 -5 -2 2 5 -4 -3 3 4 9

Sample Output

:-) Matrioshka!
:-( Try again.
:-( Try again.
:-) Matrioshka!
:-( Try again.
:-) Matrioshka!
:-( Try again.
  • 读题8+思考10+代码20+改错10

  • 模拟、递归、规律、边界判断
  • -10 -5 -2 2 5 -4 -3 3 4 10	
    f(i,j,max) 在从i到位置j中,外层的最大值为max,内层的值的和不能大于max  10>5+4
  • 不要忘了加abs
wAAACH5BAEKAAAALAAAAAABAAEAAAICRAEAOw==
import java.util.Arrays;
import java.util.Scanner;

public class Main{
	static int arr[];
	static boolean ans = true;
	public static void main(String args[]){
		Scanner sc = new Scanner(System.in);
		while(sc.hasNext()) {
			String s[] = sc.nextLine().split(" ");
			arr = new int[s.length];
			for (int i = 0; i < s.length; i++) {
				arr[i] = Integer.parseInt(s[i]);
			}
			ans = true;
			if(arr.length%2==1) ans = false;
			f(0,arr.length-1,Math.abs(arr[0]));
			if(ans)
				System.out.println(":-) Matrioshka!");
			else
				System.out.println(":-( Try again.");
		}
	}
	static void f(int i,int j,int max) {
		int sum = 0;
		int k=i,p;
		if(k+1==j)
			if(-arr[k]!=arr[j])
				ans = false;
		while(k+1<j&&ans) {
			for (k = i+2,p=i+1; k < j; k++) {
				if(arr[p]+arr[k]==0) {
					sum += Math.abs(arr[p]);
					f(p,k,Math.abs(arr[p]));
					i = k;
					break;
				}
				if(k==j-1&&arr[p]+arr[k]!=0) ans=false;
			}
		}
		if(sum >= max) ans=false;
	}
}	

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值