ACM--数学几何--2140 Forever 0.5--水


OJ地址:http://acm.fzu.edu.cn/problem.php?pid=2140


                                          Problem 2140 Forever 0.5

Accept: 379    Submit: 1334    Special Judge
Time Limit: 1000 mSec    Memory Limit : 32768 KB

 Problem Description

Given an integer N, your task is to judge whether there exist N points in the plane such that satisfy the following conditions:

1. The distance between any two points is no greater than 1.0.

2. The distance between any point and the origin (0,0) is no greater than 1.0.

3. There are exactly N pairs of the points that their distance is exactly 1.0.

4. The area of the convex hull constituted by these N points is no less than 0.5.

5. The area of the convex hull constituted by these N points is no greater than 0.75.

 Input

The first line of the date is an integer T, which is the number of the text cases.

Then T cases follow, each contains an integer N described above.

1 <= T <= 100, 1 <= N <= 100

 Output

For each case, output “Yes” if this kind of set of points exists, then output N lines described these N points with its coordinate. Make true that each coordinate of your output should be a real number with AT MOST 6 digits after decimal point.

Your answer will be accepted if your absolute error for each number is no more than 10-4.

Otherwise just output “No”.

See the sample input and output for more details.

 Sample Input

3235

 Sample Output

NoNoYes0.000000 0.525731-0.500000 0.162460-0.309017 -0.4253250.309017 -0.4253250.500000 0.162460


================================华丽的分割线=========================



题目大意:给出n,要求找出n个点,满足:

1)任意两点间的距离不超过1;

2)每个点与(0,0)点的距离不超过1;

3)有n对点之间的距离刚好为1;

4)n个点组成的多边形面积大于0.5;

5)n个点组成的多边形面积小于0.75;


解题思路:其实题目的样例是由误导性的,只要以原点为顶点,做一个边长为1的等边三角形,然后确定第4个点(4点一下都是不满足的情况,因为三点的面积是sqrt(3)/2刚好差1/2一点),剩下的就是在一原点为圆心,半径为1的圆上任意取点,注意不要取得点与已选点的距离超过1.



#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <cstdlib>  
#include <cmath>  
using namespace std;  
double x[110],y[110];  
const double temp=0.001;  
void solve()  
{  
    x[0]=0,y[0]=0;//原点  
    x[1]=1,y[1]=0;//第二个点  
    x[2]=0.5,y[2]=sqrt(1-0.25);//等边三角形的三个点   
    x[3]=0.5,y[3]=y[2]-1;  
    for(int i=4;i<110;i++)  
    {  
        y[i]=i*temp;//离散化  
        x[i]=sqrt(1-y[i]*y[i]);  
    }  
}  
int main()  
{  
    int t,n;  
    solve();  
    cin>>t;  
    while(t--)  
    {  
        cin>>n;  
        if(n<4)  
            printf("No\n");  
        else  
        {  
            printf("Yes\n");  
            for(int i=0;i<n;i++)  
              printf("%.6lf %.6lf\n",y[i],x[i]);  
        }  
    }  
    return 0;  
}  



  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值