HDOJ 题目地址:传送门
Fibonacci Again
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 51982 Accepted Submission(s): 24582
Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
Output
Print the word "yes" if 3 divide evenly into F(n).
Print the word "no" if not.
Print the word "no" if not.
Sample Input
0 1 2 3 4 5
Sample Output
no no yes no no no
题意:Fil数列,第一做的时候用递归,结果超内存,后来测试结果发现数据大一点就卡到不行,后来打了一个表,然后就过了
#include<stdio.h>
#include<iostream>
using namespace std;
int result[1000001];
int main(){
int n;
result[0]=7%3;
result[1]=11%3;
for(int i=2;i<1000001;i++){
result[i]=(result[i-1]+result[i-2])%3;
}
while(scanf("%d",&n)!=EOF){
if(result[n]){
printf("no\n");
}else{
printf("yes\n");
}
}
}