ACM--哈利波特电影票--HDOJ 1133--Buy the Ticket--递推


HDOJ题目地址:传送门


Buy the Ticket

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 6163    Accepted Submission(s): 2595


Problem Description
The "Harry Potter and the Goblet of Fire" will be on show in the next few days. As a crazy fan of Harry Potter, you will go to the cinema and have the first sight, won’t you?

Suppose the cinema only has one ticket-office and the price for per-ticket is 50 dollars. The queue for buying the tickets is consisted of m + n persons (m persons each only has the 50-dollar bill and n persons each only has the 100-dollar bill).

Now the problem for you is to calculate the number of different ways of the queue that the buying process won't be stopped from the first person till the last person. 
Note: initially the ticket-office has no money. 

The buying process will be stopped on the occasion that the ticket-office has no 50-dollar bill but the first person of the queue only has the 100-dollar bill.
 

Input
The input file contains several test cases. Each test case is made up of two integer numbers: m and n. It is terminated by m = n = 0. Otherwise, m, n <=100.
 

Output
For each test case, first print the test number (counting from 1) in one line, then output the number of different ways in another line.
 

Sample Input
  
  
3 0 3 1 3 3 0 0
 

Sample Output
  
  
Test #1: 6 Test #2: 18 Test #3: 180


题解:

 
 
现在我们假设 拿50的人用 ‘0’表示, 拿100的人用 1 表示。 如果有这么一个序列 0101101001001111..........  当第K个位置出现1的个数多余0的个数时就是一个不合法序列了  假设m=4 n=3的一个序列是:0110100 显然,它不合法, 现在我们把它稍微变化一下:  把第二个1(这个1前面的都是合法的)后面的所有位0变成1,1变成0  就得到 0111011 这个序列1的数量多于0的数量, 显然不合法, 但现在的关键不是看这个序列是不是合法的  关键是:它和我们的不合法序列 0110100 成一一对应的关系  也就是说任意一个不合法序列(m个0,n个1), 都可以由另外一个序列(n-1个0和m+1个1)得到  另外我们知道,一个序列要么是合法的,要么是不合法的  所以,合法序列数量 = 序列总数量 - 不合法序列的总量  序列总数可以这样计算m+n 个位置中, 选择 n 个位置出来填上 1, 所以是 C(m+n, n)  不合法序列的数量就是: m+n 个位置中, 选择 m+1 个位置出来填上 1 所以是 C(m+n, m+1)  然后每个人都是不一样的,所以需要全排列 m! * n! 所以最后的公式就是(C(m+n, n)-C(m+n, m+1))*m!*n! 化简后为 (m+n)!*(m-n+1)/(m+1);
  所以最后只要算(m+n)!*(m-n+1)/(m+1);就行了

import java.math.BigDecimal;
import java.math.BigInteger;
import java.util.Scanner;

public class Main {
   public static void main(String[] args) {
	  Scanner cin = new Scanner(System.in);
	  int index=1;
	  while(true){
		 int m=cin.nextInt();
		 int n=cin.nextInt();
		 if(m+n==0){
			 break;
		 }
		 System.out.println("Test #"+(index++)+":");
		 BigDecimal big;
		 if(m<n){
			 big=BigDecimal.ZERO;
		 }else{
			 big=BigDecimal.ONE;
			 for(int i=1;i<=(m+n);i++)
				 big=big.multiply(new BigDecimal(i));
			 big=big.multiply(new BigDecimal(m-n+1));
			 big=big.divide(new BigDecimal(m+1)); 
		 }
		 System.out.println(big.toPlainString());
		
	  }
   }
}

   
   




参考博客:点击打开链接

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值