2395:Out of Hay(最小生成树)

该博客讲述了Bessie奶牛在解决hay短缺问题时遇到的路径规划挑战。在N个农场间有M条连接的双向道路,Bessie需要找到最远距离的路段以确定所需的水量。她计划选择路线使得最长的路段长度最小。输入描述了农场和道路的信息,输出是需要穿越的最长道路长度。示例中,最长道路长度为43。
摘要由CSDN通过智能技术生成

2395:Out of Hay

总时间限制: 1000ms 内存限制: 65536kB
描述
The cows have run out of hay, a horrible event that must be remedied immediately. Bessie intends to visit the other farms to survey their hay situation. There are N (2 <= N <= 2,000) farms (numbered 1..N); Bessie starts at Farm 1. She’ll traverse some or all of the M (1 <= M <= 10,000) two-way roads whose length does not exceed 1,000,000,000 that connect the farms. Some farms may be multiply connected with different length roads. All farms are connected one way or another to Farm 1.

Bessie is trying to decide how large a waterskin she will need. She knows that she needs one ounce of water for each unit of length of a road. Since she can get more water at each farm, she’s only concerned about the length of the longest road. Of course, she plans her route between farms such that she minimizes the amount of water she must carry.

Help Bessie know the largest amount of water she will ever have to carry: what is the length of longest road she’ll have to travel between any two farms, presuming she chooses routes that minimize that number? This means, of course, that she might backtrack over a road in order to minimize the length of the longest road she’ll have to traverse.
输入
* Line 1: Two space-separated integers, N and M.

  • Lines 2..1+M: Line i+1 contains three space-separated integers, A_i, B_i, and L_i, describing a road from A_i to B_i of length L_i.
    输出
  • Line 1: A single integer that is the length of the longest road required to be traversed.
    样例输入
    3 3
    1 2 23
    2 3 1000
    1 3 43
    样例输出
    43
    提示
    OUTPUT DETAILS:

In order to reach farm 2, Bessie travels along a road of length 23. To reach farm 3, Bessie travels along a road of length 43. With capacity 43, she can travel along these roads provided that she refills her tank to maximum capacity before she starts down a road.

#include<iostream>
using namespace std;
//http://bailian.openjudge.cn/practice/2395/
//最小生成树简单变种,但是注意题目中说的两点之间可能有多条路径相连,所有用Min取一下最小的
//ll类型的数组,内部变量可以是Int的,所有for循环可以int 
typedef long long ll;
ll INF=5000000000;
int n,m;
ll path[2200][2200],d[2200],res;
bool used[2200];
void prim(){
    for(int i=1;i<=n;i++){
        d[i]=INF;
        used[i]=false;
    }
    res=0;
    d[1]=0;
    while(true){
        int v=-1;
        for(int i=1;i<=n;i++){
            if(!used[i]&&(v==-1||d[i]<d[v])){
                v=i;
            }
        }
        if(v==-1)break;
        res=max(res,d[v]);
        used[v]=true;
        for(int i=1;i<=n;i++){
            d[i]=min(d[i],path[v][i]);
        }
    }

}
int main(){
    cin>>n>>m;
    for(int i=1;i<=n;i++){
        for(int j=1;j<=n;j++){
            path[i][j]=INF;
        }
    }
    for(int i=0;i<m;i++){
        int a,b;ll l;
        cin>>a>>b>>l;
        path[a][b]=min(path[a][b],l);
        path[b][a]=min(path[b][a],l);
    }

    prim();
    cout<<res<<endl;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值