1979:Red and Black

1979:Red and Black

总时间限制:
1000ms
内存限制:
65536kB

描述
There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can’t move on red tiles, he can move only on black tiles.

Write a program to count the number of black tiles which he can reach by repeating the moves described above.

输入
The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20.

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows.

'.' - a black tile
'#' - a red tile
'@' - a man on a black tile(appears exactly once in a data set)
The end of the input is indicated by a line consisting of two zeros.

输出
For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).
样例输入

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

样例输出

45
59
6
13
#include<iostream>
using namespace std;
//http://bailian.openjudge.cn/practice/1979/
//类似于挑战程序设计上面求水洼个数的题目
int w,h,cnt,sx,sy,dx[]={0,1,0,-1},dy[]={1,0,-1,0};
char a[30][30];
void dfs(int x,int y){
    a[x][y]='#';
    cnt++;
    for(int i=0;i<4;i++){
        int x2=x+dx[i],y2=y+dy[i];
        if(x2>=0&&x2<h&&y2>=0&&y2<w&&a[x2][y2]=='.'){
            dfs(x2,y2);
        }
    }
}
int main(){
    while(cin>>w>>h){
        if(w==0&&h==0)break;
        cnt=0;
        for(int i=0;i<h;i++){
            for(int j=0;j<w;j++){
                cin>>a[i][j];
                if(a[i][j]=='@'){
                    sx=i;sy=j;
                }
            }
        }
        dfs(sx,sy);
        cout<<cnt<<endl;
    }
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值