[ACM]POJ1979 Red and Black

18 篇文章 0 订阅
13 篇文章 0 订阅

题目来源:北京大学POJ http://poj.org/problem?id=1979

Description

There is a rectangular room, covered with square tiles. Each tile is colored either red or black. A man is standing on a black tile. From a tile, he can move to one of four adjacent tiles. But he can't move on red tiles, he can move only on black tiles. 

Write a program to count the number of black tiles which he can reach by repeating the moves described above. 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers W and H; W and H are the numbers of tiles in the x- and y- directions, respectively. W and H are not more than 20. 

There are H more lines in the data set, each of which includes W characters. Each character represents the color of a tile as follows. 

'.' - a black tile 
'#' - a red tile 
'@' - a man on a black tile(appears exactly once in a data set) 
The end of the input is indicated by a line consisting of two zeros. 

Output

For each data set, your program should output a line which contains the number of tiles he can reach from the initial tile (including itself).

Sample Input

6 9
....#.
.....#
......
......
......
......
......
#@...#
.#..#.
11 9
.#.........
.#.#######.
.#.#.....#.
.#.#.###.#.
.#.#..@#.#.
.#.#####.#.
.#.......#.
.#########.
...........
11 6
..#..#..#..
..#..#..#..
..#..#..###
..#..#..#@.
..#..#..#..
..#..#..#..
7 7
..#.#..
..#.#..
###.###
...@...
###.###
..#.#..
..#.#..
0 0

Sample Output

45
59
6
13

这个题目可以用回溯法解决,跟我博客里面的“贪吃蛇游戏”有些类似,见代码:

// RedAndBlack.cpp : 定义控制台应用程序的入口点。
//

#include "stdafx.h"
#include <stdio.h>
#include <string.h>
char matrix[20][20];
int path = 0;
int rows;
int cols;
void search(int m, int n)
{
	if (m >= 0 && n >= 0 && m < rows && n < cols && (matrix[m][n] == '@' || matrix[m][n] == '.' ) )
	{
		path++;
		matrix[m][n] = '0';
		search(m,n+1);
		search(m+1,n);
		search(m-1,n);
		search(m,n-1);
	}
}

int main()
{
	int i,j,m,n;
	//freopen("in.txt","r",stdin);
	while(1)
	{
		memset(matrix,'\0',20*20);
		path = 0;
		scanf("%d %d\n",&cols,&rows);
		if (cols == 0)
			break;
		for (i = 0; i < rows; i++)
			for (j = 0; j < cols; j++)
			{
				scanf("%c ",&matrix[i][j]);
				if (matrix[i][j] == '@')
				{
					m = i;
					n = j;
				}
			}
			search(m,n);
			printf("%d\n",path);
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值