poj 3468

A Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 70414 Accepted: 21714
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


线段树的区间更新,和区间查询。定义的是int 输入用了lld.所以WA了好几次。注意代码中的红色部分,更新,上面的add就好,原来的查询的时候在更新。

第一次写有点搓了。
//3468
#include <iostream>
#include <cstdio>
#include <cstring>
#include <map>
#include <queue>
#include <stack>
#include <algorithm>
#include <cstdlib>


using namespace std;


struct node
{
long long l,r;
long long sum;
long long add;
};
node tree[400001]={};
int data[100001]={};
long long N,Q;
void built(long long n,long long left,long long right)
{
tree[n].add = 0;
tree[n].l = left;
tree[n].r = right;
if(left == right)
{
tree[n].sum = data[left];
return ;
}
long long mid = (left+right) / 2;
built(n*2,left,mid);
built(n*2+1,mid+1,right);
tree[n].sum = tree[n*2].sum + tree[n*2+1].sum;
}


void updata(long long n,long long left,long long right,long long value)
{
if(tree[n].l == left && tree[n].r == right)
{
tree[n].add += value;
tree[n].sum += value*(right - left + 1); 
return ;
}
if(tree[n].add)
{
tree[n*2].add += tree[n].add;
tree[n*2].sum += tree[n].add * (tree[n*2].r - tree[n*2].l + 1);
tree[n*2+1].add += tree[n].add;
tree[n*2+1].sum += tree[n].add * (tree[n*2+1].r - tree[n*2+1].l + 1);
tree[n].add = 0;
}
if(tree[n*2].r < left)
 updata(n*2+1,left,right,value);
else if(tree[n*2+1].l > right)
 updata(n*2,left,right,value);
else
{
updata(n*2,left,tree[n*2].r,value);
updata(n*2+1,tree[n*2+1].l,right,value);
}
tree[n].sum = tree[n*2].sum + tree[n*2+1].sum;
}


long long query(long long n,long long left,long long right)
{
if(tree[n].l == left && tree[n].r == right)
return tree[n].sum;


if(tree[n].add)
{
tree[n*2].add += tree[n].add;
tree[n*2].sum += tree[n].add * (tree[n*2].r - tree[n*2].l + 1);
tree[n*2+1].add += tree[n].add;
tree[n*2+1].sum += tree[n].add * (tree[n*2+1].r - tree[n*2+1].l + 1);
tree[n].add = 0;
}
if(tree[n*2].r < left)
 return query(n*2+1,left,right);
else if(tree[n*2+1].l > right)
return query(n*2,left,right);
else
{
long long sum = 0;
sum = query(n*2,left,tree[n*2].r);
sum += query(n*2+1,tree[n*2+1].l,right);
return sum;
}
}
int main()
{
scanf("%d%d",&N,&Q);
for(int i = 1; i <= N; i++)
 scanf("%d",&data[i]);
built(1,1,N); 




char d;long long a,b,c;
for(int i = 0; i < Q; i++)
{
scanf(" %c",&d);
if(d == 'C')
{
scanf(" %lld %lld %lld",&a,&b,&c);
updata(1,a,b,c);
}
if(d == 'Q')
{
scanf(" %lld %lld",&a,&b);
long long sum = query(1,a,b);
printf("%lld\n",sum);
}
}
return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值