poj-1840-Eqs 哈希(hash)



Eqs
Time Limit: 5000MS Memory Limit: 65536K
Total Submissions: 13400 Accepted: 6579

Description

Consider equations having the following form:
a1x1 3+ a2x2 3+ a3x3 3+ a4x4 3+ a5x5 3=0
The coefficients are given integers from the interval [-50,50].
It is consider a solution a system (x1, x2, x3, x4, x5) that verifies the equation, xi∈[-50,50], xi != 0, any i∈{1,2,3,4,5}.

Determine how many solutions satisfy the given equation.

Input

The only line of input contains the 5 coefficients a1, a2, a3, a4, a5, separated by blanks.

Output

The output will contain on the first line the number of the solutions for the given equation.

Sample Input

37 29 41 43 47

Sample Output

654

Source



将公式变形,左边留下x1,x2, x3,这样可以先算左值,表示一个数组的下标,数组内存次数,

再计算右值,作为下标寻找次数,也就是映射,即哈希(hash)。

注意计算结果有正负,所以应将hash数组扩大一倍,并用short,否则会mle。



#include<stdio.h>
#include<string.h>
#define ll long long
#define maxn 18750000
short has[maxn*2+7];
ll cnt=0;
int main()
{
    //memset(has, sizeof(has), 0);
    int a1, a2, a3, a4, a5;
    short x1, x2, x3, x4, x5;
    int ans;
    scanf("%d%d%d%d%d", &a1, &a2, &a3, &a4, &a5);
    for(x1=-50;x1<=50;x1++){
        if(!x1) continue;
        for(x2=-50;x2<=50;x2++){
            if(!x2) continue;
            for(x3=-50;x3<=50;x3++){
                if(!x3) continue;
                ans=a1*x1*x1*x1+a2*x2*x2*x2+a3*x3*x3*x3;
                has[ans+maxn]++;
            }
        }
    }
    for(x4=-50;x4<=50;x4++){
        if(!x4) continue;
        for(x5=-50;x5<=50;x5++){
            if(!x5) continue;
            ans=-(a4*x4*x4*x4+a5*x5*x5*x5);
            cnt+=has[ans+maxn];
        }
    }
    printf("%I64u\n", cnt);
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值