hdu 1052 Tian Ji -- The Horse Racing

Tian Ji -- The Horse Racing
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 29464 Accepted Submission(s): 8861


Problem Description
Here is a famous story in Chinese history.

"That was about 2300 years ago. General Tian Ji was a high official in the country Qi. He likes to play horse racing with the king and others."

"Both of Tian and the king have three horses in different classes, namely, regular, plus, and super. The rule is to have three rounds in a match; each of the horses must be used in one round. The winner of a single round takes two hundred silver dollars from the loser."

"Being the most powerful man in the country, the king has so nice horses that in each class his horse is better than Tian's. As a result, each time the king takes six hundred silver dollars from Tian."

"Tian Ji was not happy about that, until he met Sun Bin, one of the most famous generals in Chinese history. Using a little trick due to Sun, Tian Ji brought home two hundred silver dollars and such a grace in the next match."

"It was a rather simple trick. Using his regular class horse race against the super class from the king, they will certainly lose that round. But then his plus beat the king's regular, and his super beat the king's plus. What a simple trick. And how do you think of Tian Ji, the high ranked official in China?"



Were Tian Ji lives in nowadays, he will certainly laugh at himself. Even more, were he sitting in the ACM contest right now, he may discover that the horse racing problem can be simply viewed as finding the maximum matching in a bipartite graph. Draw Tian's horses on one side, and the king's horses on the other. Whenever one of Tian's horses can beat one from the king, we draw an edge between them, meaning we wish to establish this pair. Then, the problem of winning as many rounds as possible is just to find the maximum matching in this graph. If there are ties, the problem becomes more complicated, he needs to assign weights 0, 1, or -1 to all the possible edges, and find a maximum weighted perfect matching...

However, the horse racing problem is a very special case of bipartite matching. The graph is decided by the speed of the horses --- a vertex of higher speed always beat a vertex of lower speed. In this case, the weighted bipartite matching algorithm is a too advanced tool to deal with the problem.

In this problem, you are asked to write a program to solve this special case of matching problem.


Input
The input consists of up to 50 test cases. Each case starts with a positive integer n (n <= 1000) on the first line, which is the number of horses on each side. The next n integers on the second line are the speeds of Tian’s horses. Then the next n integers on the third line are the speeds of the king’s horses. The input ends with a line that has a single 0 after the last test case.


Output
For each input case, output a line containing a single number, which is the maximum money Tian Ji will get, in silver dollars.


Sample Input

3
92 83 71
95 87 74
2
20 20
20 20
2
20 19
22 18
0



Sample Output

200
0
0



题意:田忌赛马的故事。每次比赛都有二百两银子的奖励,问田忌最多可获得多少银子?


思路:这其实就是贪心的思想,既然是让求田忌可获得最多的价值是多少,那么我就尽可能的让田忌赢不就可以了。  那么首先我们要比较第一匹马的速度(要按照从大到进行一次排序),如果是田忌的快,那么就这两匹马进行比赛(下标随之往后移动),如果是国王的马快,那么我在比较最后一匹马(也就是速度最慢的)的马,如果是田忌的快,那么就这两匹马比赛(下标随之往前移动),如果是国王的快,那么我就拿最慢的马去和国王最快的马比赛(下标随之移动),这样的话我可以保证田忌最快的马一定可以赢。

刚开始的位置如图所示:


经过第一步比较:如果田忌的马比过往的快,下标往后移动。如图:


如果田忌的马慢的话,那么就比较最慢的马,如果田忌最慢的马比国王最慢的马快,那么下标随之往前移动。如图:


如果田忌最慢的马比国王最慢的马还慢的话,那么我就拿田忌最慢的马去和国王最快的马比较。下标随之移动,如图:


总而言之就是找到田忌比国王慢的马,然后拿这匹慢马去和国王快的马比,这样就能满足田忌赢得次数最多。


AC代码:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
bool cmp(int x, int y)
{
    return x > y;
}
int main()
{
    int n;
    while(~scanf("%d",&n)&&n)
    {
        int King[3001], Tian[3001];
        int t = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&Tian[i]);
        }
        for(int i = 0; i < n; i++)
        {
            scanf("%d",&King[i]);
        }
        sort(Tian, Tian + n, cmp);
        sort(King, King + n, cmp);
        int s1 = 0, s2 = 0;
        int e1 = n - 1, e2 = n - 1;
        int sum = 0;
        while(n--)
        {
            if(Tian[s1] > King[s2])   ///田忌最快的马比国王最快的马快
            {
                s1++, s2++;
                sum++;
            }
            else if(Tian[e1] > King[e2])        ///田忌最慢的马比国王最慢的马快
            {
                e1--, e2--;
                sum++;
            }
            else if(Tian[e1] < King[s2])        ///田忌最慢的马比国王最快的慢
            {
                e1--, s2++;
                sum--;
            }
        }
        printf("%d\n",sum*200);
    }

    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
资源包主要包含以下内容: ASP项目源码:每个资源包中都包含完整的ASP项目源码,这些源码采用了经典的ASP技术开发,结构清晰、注释详细,帮助用户轻松理解整个项目的逻辑和实现方式。通过这些源码,用户可以学习到ASP的基本语法、服务器端脚本编写方法、数据库操作、用户权限管理等关键技术。 数据库设计文件:为了方便用户更好地理解系统的后台逻辑,每个项目中都附带了完整的数据库设计文件。这些文件通常包括数据库结构图、数据表设计文档,以及示例数据SQL脚本。用户可以通过这些文件快速搭建项目所需的数据库环境,并了解各个数据表之间的关系和作用。 详细的开发文档:每个资源包都附有详细的开发文档,文档内容包括项目背景介绍、功能模块说明、系统流程图、用户界面设计以及关键代码解析等。这些文档为用户提供了深入的学习材料,使得即便是从零开始的开发者也能逐步掌握项目开发的全过程。 项目演示与使用指南:为帮助用户更好地理解和使用这些ASP项目,每个资源包中都包含项目的演示文件和使用指南。演示文件通常以视频或图文形式展示项目的主要功能和操作流程,使用指南则详细说明了如何配置开发环境、部署项目以及常见问题的解决方法。 毕业设计参考:对于正在准备毕业设计的学生来说,这些资源包是绝佳的参考材料。每个项目不仅功能完善、结构清晰,还符合常见的毕业设计要求和标准。通过这些项目,学生可以学习到如何从零开始构建一个完整的Web系统,并积累丰富的项目经验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值