hdu 3367 Pseudoforest

Pseudoforest

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 2907    Accepted Submission(s): 1144


Problem Description
In graph theory, a pseudoforest is an undirected graph in which every connected component has at most one cycle. The maximal pseudoforests of G are the pseudoforest subgraphs of G that are not contained within any larger pseudoforest of G. A pesudoforest is larger than another if and only if the total value of the edges is greater than another one’s.

 

Input
The input consists of multiple test cases. The first line of each test case contains two integers, n(0 < n <= 10000), m(0 <= m <= 100000), which are the number of the vertexes and the number of the edges. The next m lines, each line consists of three integers, u, v, c, which means there is an edge with value c (0 < c <= 10000) between u and v. You can assume that there are no loop and no multiple edges.
The last test case is followed by a line containing two zeros, which means the end of the input.
 

Output
Output the sum of the value of the edges of the maximum pesudoforest.
 

Sample Input
  
  
3 3 0 1 1 1 2 1 2 0 1 4 5 0 1 1 1 2 1 2 3 1 3 0 1 0 2 2 0 0
 

Sample Output
  
  
3 5
 

Source
“光庭杯”第五届华中北区程序设计邀请赛 暨 WHU第八届程序设计竞赛

题意:在图论中,如果一个森林中有很多连通分量,并且每个连通分量中至多有一个环,那么这个森林就称为伪森林。现在给出一个森林,求森林包含的最大的伪森林,其大小通过所有边的权值之和来比较。

根据题目的要求我们再合并两棵树的时候要判断是否有环:
1.两棵树都有环,那么不能合并(要求最多一个环)
2.如果一棵树有,另一棵没有,那么可以直接合并,并把有环的树标记。
3.如果两棵树都没有环,那么可以直接合并。
如果要查找的这两个点在同一棵树上,并且该数还没有环,那么就把这两点连在一起构成环,标记即可。

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <algorithm>
#define INF 0x3f3f3f3f
#define MAX 1005
using namespace std;
struct Edge
{
    int u, v, w;
}edge[100004];
int vis[10004], pre[10004];
int cmp(Edge x, Edge y)
{
    return x.w > y.w;
}
int Find(int x)
{
    while(x!=pre[x])
        x = pre[x];
    return x;
}
int main()
{
    int n, m;
    while(~scanf("%d%d",&n, &m))
    {
        if(n==0&&m==0)
            break;
        memset(vis, 0, sizeof(vis));
        for(int i = 0; i < n; i++)
            pre[i] = i;
        for(int i = 0; i < m; i++)
        {
            scanf("%d%d%d",&edge[i].u, &edge[i].v, &edge[i].w);
        }
        sort(edge, edge + m, cmp); ///把边排序

        int sum = 0;

        for(int i = 0; i < m; i++)
        {
            int a = Find(edge[i].u);
            int b = Find(edge[i].v);
            if(a!=b) ///a和b不在同一个环中
            {
                if(!vis[a]&&!vis[b])  ///两棵树都没有环
                {
                    sum += edge[i].w;
                    pre[a] = b;
                }
                else if(!vis[a])  ///a中没有环
                {
                    sum += edge[i].w;
                    pre[a] = b;
                }
                else if(!vis[b])///b中没有环
                {
                    sum += edge[i].w;
                    pre[b] = a;
                }
            }
            else if(vis[a] == 0)///如果两点在一棵树上 并且这棵树还没有环  那么就添加一个环
            {
                sum += edge[i].w;
                vis[a] = 1;
            }
        }
        printf("%d\n",sum);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值