poj 2553 The Bottom of a Graph

The Bottom of a Graph
Time Limit: 3000MS
Memory Limit: 65536K
Total Submissions: 10912
Accepted: 4497

Description

We will use the following (standard) definitions from graph theory. Let V be a nonempty and finite set, its elements being called vertices (or nodes). Let E be a subset of the Cartesian product V×V, its elements being called edges. Then G=(V,E) is called a directed graph.
Let n be a positive integer, and let p=(e1,...,en) be a sequence of length n of edges ei∈E such that ei=(vi,vi+1) for a sequence of vertices (v1,...,vn+1). Then p is called a path from vertex v1 to vertex vn+1 in G and we say that vn+1 is reachable from v1, writing (v1→vn+1).
Here are some new definitions. A node v in a graph G=(V,E) is called a sink, if for every node w in G that is reachable from v, v is also reachable from w. The bottom of a graph is the subset of all nodes that are sinks, i.e., bottom(G)={v∈V|∀w∈V:(v→w)⇒(w→v)}. You have to calculate the bottom of certain graphs.

Input

The input contains several test cases, each of which corresponds to a directed graph G. Each test case starts with an integer number v, denoting the number of vertices of G=(V,E), where the vertices will be identified by the integer numbers in the set V={1,...,v}. You may assume that 1<=v<=5000. That is followed by a non-negative integer e and, thereafter, e pairs of vertex identifiers v1,w1,...,ve,we with the meaning that (vi,wi)∈E. There are no edges other than specified by these pairs. The last test case is followed by a zero.

Output

For each test case output the bottom of the specified graph on a single line. To this end, print the numbers of all nodes that are sinks in sorted order separated by a single space character. If the bottom is empty, print an empty line.

Sample Input

3 3
1 3 2 3 3 1
2 1
1 2
0

Sample Output

1 3
2

Source

Ulm Local 2003

题目大意:如果v点能够到的点,反过来能够到达v点,则称这个点为sink点,输出所有的sink点
解题思路:求连通分量,然后出度为0的连通分量里面的点就是sink点

AC代码:
#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
#include <stack>
using namespace std;
#define MAX 100005
#define MAXN 500005
struct Edge
{
    int u;
    int v;
    int next;
} edge[MAXN];
int DFN[MAX], low[MAX], in[MAX], out[MAX];
int flag[MAX], step[MAX], head[MAX];
int sum[MAX];
stack<int>S;
int res, tot, M, ans, ans1, N;
void Init()
{
    memset(DFN, 0, sizeof(DFN));
    memset(low, 0, sizeof(low));
    memset(in, 0, sizeof(in));
    memset(out, 0, sizeof(out));
    memset(flag, 0, sizeof(flag));
    memset(head, -1, sizeof(head));
    memset(sum, 0, sizeof(sum));
    memset(edge, 0, sizeof(edge));
    memset(step, 0, sizeof(step));
    if(!S.empty())
        S.pop();
    tot = 0, res = 0;
}
void addedge(int u, int v, int k)
{
    edge[k].u = u, edge[k].v = v, edge[k].next = head[u], head[u] = k;
}
void tarjan(int u)
{
    DFN[u] = low[u] = ++tot;
    flag[u] = 1;
    S.push(u);
    for(int j = head[u]; j != -1; j = edge[j].next) ///更新low值
    {
        int v = edge[j].v;
        if(!DFN[v])
        {
            tarjan(v);
            low[u] = min(low[u],low[v]);
        }
        else if(flag[v])
        {
            low[u] = min(low[u],low[v]);
        }
    }

    int v;
    if(DFN[u]==low[u]) ///缩点
    {
        do
        {
            v = S.top();
            S.pop();
            step[v] = res;
            sum[res]++;
            flag[v] = 0;
        }
        while(u!=v);
        res++;
    }
}
void solve()
{
    for(int i=0; i<N; i++)
        for(int j=head[i]; j!=-1; j=edge[j].next) ///统计缩点后的各点的出度
        {
            if(step[i]!=step[edge[j].v])
                out[step[i]]++;
        }
    int f, yy=0;
    for(int i = 0; i < N; i++)
    {
        if(!out[step[i]])
            flag[i] = 1;
    }
    for(int i = 0; i < N; i++)
    {
        if(flag[i])
            printf("%d ",i + 1);
    }
    printf("\n");
}
int main()
{
    while(~scanf("%d",&N)&&N)
    {
        scanf("%d",&M);
        Init();
        for(int i = 0; i < M; i++)
        {
            int a, b;
            scanf("%d%d",&a,&b);
            addedge(a-1,b-1,i); ///建图
        }
        for(int i = 0; i < N; i++)
        {
            if(!DFN[i])
            {
                tarjan(i);
            }
        }
        solve();
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园建设方案旨在通过融合先进技术,如物联网、大数据、人工智能等,实现校园的智能化管理与服务。政策的推动和技术的成熟为智慧校园的发展提供了基础。该方案强调了数据的重要性,提出通过数据的整合、开放和共享,构建产学研资用联动的服务体系,以促进校园的精细化治理。 智慧校园的核心建设任务包括数据标准体系和应用标准体系的建设,以及信息化安全与等级保护的实施。方案提出了一站式服务大厅和移动校园的概念,通过整合校内外资源,实现资源共享平台和产教融合就业平台的建设。此外,校园大脑的构建是实现智慧校园的关键,它涉及到数据中心化、数据资产化和数据业务化,以数据驱动业务自动化和智能化。 技术应用方面,方案提出了物联网平台、5G网络、人工智能平台等新技术的融合应用,以打造多场景融合的智慧校园大脑。这包括智慧教室、智慧实验室、智慧图书馆、智慧党建等多领域的智能化应用,旨在提升教学、科研、管理和服务的效率和质量。 在实施层面,智慧校园建设需要统筹规划和分步实施,确保项目的可行性和有效性。方案提出了主题梳理、场景梳理和数据梳理的方法,以及现有技术支持和项目分级的考虑,以指导智慧校园的建设。 最后,智慧校园建设的成功依赖于开放、协同和融合的组织建设。通过战略咨询、分步实施、生态建设和短板补充,可以构建符合学校特色的生态链,实现智慧校园的长远发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值