Line belt (三分查找)

Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 629 Accepted Submission(s): 325

Problem Description
In a two-dimensional plane there are two line belts, there are two segments AB and CD, lxhgww’s speed on AB is P and on CD is Q, he can move with the speed R on other area on the plane.
How long must he take to travel from A to D?

Input
The first line is the case number T.
For each case, there are three lines.
The first line, four integers, the coordinates of A and B: Ax Ay Bx By.
The second line , four integers, the coordinates of C and D:Cx Cy Dx Dy.
The third line, three integers, P Q R.
0<= Ax,Ay,Bx,By,Cx,Cy,Dx,Dy<=1000
1<=P,Q,R<=10

Output
The minimum time to travel from A to D, round to two decimals.

Sample Input
1
0 0 0 100
100 0 100 100
2 2 1

Sample Output
136.60
/*
自己弄了老一会才弄出来 就是一个典型的三分算法 不过这个题是一个三分套三分算法 首先我们先对ab线段求三分一边求一边对cd线段求三分 然后算出时间最短 最后算出来ab的三分点 然后cd自然也就算出来了 不过知得一个注意的地方的是再求距离时需要加上一个0.000001吧 不加就错了 我也搞不懂了
*/

#include<iostream>
#include<stdio.h>
#include<algorithm>
#include<math.h>
#include<string.h>

using namespace std;

typedef struct Point{
    double x;
    double y;
}point;
point a,b,c,d;
point bb,dd;
double ab,cd;
double p,q,r;
double path(point m,point n){
    return sqrt(0.0000001+pow(m.x - n.x,2.0) + pow(m.y - n.y,2.0));
}
double work(double t){
    dd.x = d.x + (c.x - d.x)/cd * t * q;
    dd.y = d.y + (c.y - d.y)/cd * t *q;
    return t + path(bb,dd)/r;
}
double sanfen1(double t){
    bb.x = a.x + (b.x - a.x)/ab* t* p;
    bb.y = a.y + (b.y - a.y)/ab * t* p;
    double l = 0;
    double r = cd/q;
    double mid ,mmid;
    while((r-l)>0.0000001){
        mid = l + (r-l)/3;
        mmid = r - (r-l)/3;
        if(work(mid)<work(mmid)){
            r = mmid;
        }else
            l = mid;
    }
    return t + work(l);
}
int main(){
    int ncase;
    cin>>ncase;
    while(ncase--){
        cin>>a.x>>a.y>>b.x>>b.y;
        cin>>c.x>>c.y>>d.x>>d.y;
        cin>>p>>q>>r;
        ab = path(a,b);
        cd = path(c,d);
        double l =0,r = ab/p;
        double mid;
        double mmid;
        while((r-l)>0.000001){
             mid = l + (r - l)/3;
             mmid = r - (r - l)/3;
            if(sanfen1(mid)<sanfen1(mmid))
                r = mmid;
            else
                l = mid;
        }
        printf("%.2f\n",sanfen1(mid));
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值