pat甲1021.Deepest Root(简单dfs)

58 篇文章 0 订阅

1021. Deepest Root (25)

时间限制
1500 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A graph which is connected and acyclic can be considered a tree. The height of the tree depends on the selected root. Now you are supposed to find the root that results in a highest tree. Such a root is called the deepest root.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive integer N (<=10000) which is the number of nodes, and hence the nodes are numbered from 1 to N. Then N-1 lines follow, each describes an edge by given the two adjacent nodes' numbers.

Output Specification:

For each test case, print each of the deepest roots in a line. If such a root is not unique, print them in increasing order of their numbers. In case that the given graph is not a tree, print "Error: K components" where K is the number of connected components in the graph.

Sample Input 1:
5
1 2
1 3
1 4
2 5
Sample Output 1:
3
4
5
Sample Input 2:
5
1 3
1 4
2 5
3 4
Sample Output 2:
Error: 2 components
tips:
题意是找出一个树中使得树的深度最大的根节点,如果有多个,则升序输出。

一道入门的搜索题了。注意到题目中给出点的数目多达10000个,使用邻接表是必要的
我是先深搜找出联通分量的个数,如果是一个森林,则直接输出连通分量的个数结束。
否则,分别对每一个点再次搜索,统计每一个点作为根的时候树的深度,用一个数组存储。
注意在每次搜索的时候将标记数组清空。

以上!
#include<iostream>
#include<vector>
#include<cstring>
using namespace std;

vector<int>graph[10002];//邻接表 

int n,ans,_max;
int flag[10002];//作为根时树的深度 
int book[10002];//标记数组 


void dfs1(int step)
{
	book[step]=1;
	for(int i=0;i<graph[step].size();i++)
	{
		if(!book[graph[step][i]])
		dfs1(graph[step][i]);	
	} 
}
void dfs2(int step,int cnt)
{
	_max=max(_max,cnt);
	book[step]=1;
	for(int i=0;i<graph[step].size();i++)
	{
		if(!book[graph[step][i]])
		dfs2(graph[step][i],cnt+1);	
	} 
	
}
int main()
{
	//邻接表建图 
	cin>>n;
	for(int i=0;i<n-1;i++){
		int u,v;
		cin>>u>>v;
		graph[u].push_back(v);
		graph[v].push_back(u);
	}	
	
	for(int i=1;i<=n;i++){
		if(!book[i]){
			dfs1(i);
			ans++;
		}	
	} 
	//如果联通分量的数目不唯一 
	 if(ans>1){
	 	cout<<"Error: "<<ans<<" components"<<endl;
	 	goto tag;
	 }
	 else {
	 	for(int i=1;i<=n;i++){
	 		memset(book,0,sizeof(book));
	 		_max=0;
	 		dfs2(i,1);
	 		flag[i]=_max;
		} 
		for(int i=1;i<=n;i++){
			_max=max(_max,flag[i]);
		}
		for(int i=1;i<=n;i++){
			if(flag[i]==_max)cout<<i<<endl;
		}
	 }
	 
tag:	return 0;
}


  • 2
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值