poj 3279 Fliptile(开关问题)

Fliptile
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 9746 Accepted: 3635

Description

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word "IMPOSSIBLE".

Input

Line 1: Two space-separated integers:  M and  N 
Lines 2.. M+1: Line  i+1 describes the colors (left to right) of row i of the grid with  N space-separated integers which are 1 for black and 0 for white

Output

Lines 1.. M: Each line contains  N space-separated integers, each specifying how many times to flip that particular location.

Sample Input

4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1

Sample Output

0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0
tips:枚举第一行的翻转情况,然后进行统计。时间复杂度O(M*N*2^m)
#include<iostream>
#include<cstring>
#include<vector>

using namespace std;

int n,m,ans;//n行m列 
int tmp[16][16];//存储每个点是否进行了翻转
int map[16][16];//存储初始的格子情况 
int dst[16][16];
int dire[][2]={-1,0,1,0,0,1,0,-1,0,0};//上下左右自身 
int get(int x,int y)
{
	int t=map[x][y];
	for(int i=0;i<5;i++) //枚举5个方向
	{
		int nx=x+dire[i][0];
		int ny=y+dire[i][1];
		if(nx<0||nx>=n||ny<0||ny>=m)continue;
		t+=tmp[nx][ny];
	 } 
	 return t%2;
 } 
int calc()
{
	int cnt=0;//用于统计本情况下所有的翻转次数 
	for(int i=1;i<n;i++)//从第二行开始枚举
	for(int j=0;j<m;j++)
	{
		if(get(i-1,j)!=0)//查看正上方的格子是否为0 
		{
			tmp[i][j]=1;
		}
	 } 
	 
	 for(int i=0;i<m;i++)//枚举最后一行的情况,最后一行必须全为白色
	 {
	 	if(get(n-1,i)!=0)return -1;
	  } 
	  
	 for(int i=0;i<n;i++)	//统计所有的翻转次数 
	for(int j=0;j<m;j++){
		cnt+=tmp[i][j];
	}
	return cnt;
}
int main()
{
	while(cin>>n>>m)
	{
		ans=-1;//初始化最优值 
		for(int i=0;i<n;i++)
		for(int j=0;j<m;j++)cin>>map[i][j];
		
		for(int i=0;i<1<<m;i++)//枚举第一行的翻转情况 
		{
			memset(tmp,0,sizeof(tmp));
			for(int j=0;j<m;j++)
			{
				tmp[0][j]=(i>>j)&1;
			}
			int cnt=calc(); 
			if(cnt>=0&&(cnt<ans||ans<0))
			{
				ans=cnt;
				memcpy(dst,tmp,sizeof(tmp));
			}
		} 
		if(ans<0)cout<<"IMPOSSIBLE"<<endl;
		else {
			for(int i=0;i<n;i++)
			{
				for(int j=0;j<m;j++)
				{
					if(j==0)cout<<dst[i][j];
					else cout<<" "<<dst[i][j];
				}
				cout<<endl;
			}
			
		} 
	 } 
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
根据提供的引用内容,可以得知这是一道关于迷宫问题的题目,需要使用Java语言进行编写。具体来说,这道题目需要实现一个迷宫的搜索算法,找到从起点到终点的最短路径。可以使用广度优先搜索或者深度优先搜索算法来解决这个问题。 下面是一个使用广度优先搜索算法的Java代码示例: ```java import java.util.*; public class Main { static int[][] maze = new int[5][5]; // 迷宫地图 static int[][] dir = {{0, 1}, {0, -1}, {1, 0}, {-1, 0}}; // 方向数组 static boolean[][] vis = new boolean[5][5]; // 标记数组 static int[][] pre = new int[5][5]; // 记录路径 public static void main(String[] args) { Scanner sc = new Scanner(System.in); for (int i = 0; i < 5; i++) { for (int j = 0; j < 5; j++) { maze[i][j] = sc.nextInt(); } } bfs(0, 0); Stack<Integer> stack = new Stack<>(); int x = 4, y = 4; while (x != 0 || y != 0) { stack.push(x * 5 + y); int t = pre[x][y]; x = t / 5; y = t % 5; } stack.push(0); while (!stack.empty()) { System.out.print(stack.pop() + " "); } } static void bfs(int x, int y) { Queue<Integer> qx = new LinkedList<>(); Queue<Integer> qy = new LinkedList<>(); qx.offer(x); qy.offer(y); vis[x][y] = true; while (!qx.isEmpty()) { int tx = qx.poll(); int ty = qy.poll(); if (tx == 4 && ty == 4) { return; } for (int i = 0; i < 4; i++) { int nx = tx + dir[i][0]; int ny = ty + dir[i][1]; if (nx >= 0 && nx < 5 && ny >= 0 && ny < 5 && maze[nx][ny] == 0 && !vis[nx][ny]) { vis[nx][ny] = true; pre[nx][ny] = tx * 5 + ty; qx.offer(nx); qy.offer(ny); } } } } } ``` 该代码使用了广度优先搜索算法,首先读入迷宫地图,然后从起点开始进行搜索,直到找到终点为止。在搜索的过程中,使用标记数组记录已经访问过的位置,使用路径数组记录路径。最后,使用栈来输出路径。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值