【POJ - 3279】Fliptile 【反转特性+状压遍历字典序】

Farmer John knows that an intellectually satisfied cow is a happy cow who will give more milk. He has arranged a brainy activity for cows in which they manipulate an M × N grid (1 ≤ M ≤ 15; 1 ≤ N ≤ 15) of square tiles, each of which is colored black on one side and white on the other side.

As one would guess, when a single white tile is flipped, it changes to black; when a single black tile is flipped, it changes to white. The cows are rewarded when they flip the tiles so that each tile has the white side face up. However, the cows have rather large hooves and when they try to flip a certain tile, they also flip all the adjacent tiles (tiles that share a full edge with the flipped tile). Since the flips are tiring, the cows want to minimize the number of flips they have to make.

Help the cows determine the minimum number of flips required, and the locations to flip to achieve that minimum. If there are multiple ways to achieve the task with the minimum amount of flips, return the one with the least lexicographical ordering in the output when considered as a string. If the task is impossible, print one line with the word “IMPOSSIBLE”.

Input
Line 1: Two space-separated integers: M and N
Lines 2.. M+1: Line i+1 describes the colors (left to right) of row i of the grid with N space-separated integers which are 1 for black and 0 for white
Output
Lines 1.. M: Each line contains N space-separated integers, each specifying how many times to flip that particular location.
Sample Input
4 4
1 0 0 1
0 1 1 0
0 1 1 0
1 0 0 1
Sample Output
0 0 0 0
1 0 0 1
1 0 0 1
0 0 0 0

分析:对于反转问题,还是针对其两个很重要的特性来处理,第一:每个位置最多只会反转一次 。 第二 : 结果一样的话,不用考虑反转的顺序。、

所以对于这个问题,如果我们将第一行的操作方案确定下来,那么其余所有位置的方案也都出来了。
那么对于第一行的处理方案,我们可以用状压字典序遍历其方案。
详细的看代码吧。写的很详细。

代码

#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cmath>
using namespace std;
#define LL long long
#define ULL unsigned long long

const int N =  20;
const int M = 1e6+11;
const int inf =0x3f3f3f3f;
const int mod = 1e9+7;
const int inff = 0x3f3f3f3f3f3f3f3f;

/*-------------------------------------*/
int flip[N][N]; // 原图
int ans[N][N]; // 操作方案的答案
int opt[N][N]; // 中间过程的记录
int to[5][2]={0,0,1,0,0,1,-1,0,0,-1};
int n,m;
int getCol(int x,int y){  // 获取当前位置的 颜色
    int cnt=flip[x][y];
    for(int i=0;i<5;i++){
        int nx=x+to[i][0];
        int ny=y+to[i][1];
        if(nx<0||nx>=n||ny<0||ny>=m) continue;
        cnt+=opt[nx][ny];
    }
  //  printf("x %d y %d cnt %d \n",x,y,cnt );
    return cnt%2;
}

int solve(){
    for(int i=1;i<n;i++){
        for(int j=0;j<m;j++){
            if(getCol(i-1,j) == 1)
                opt[i][j]++; // 只有当前位置反转才可以将(i-1,j)位置翻成白色
        }
    }

    for(int j=0;j<m;j++){ // 因为优先将前n-1行反转为白色,所以最后一行不一定可以正好反转为白色
        if(getCol(n-1,j) == 1)
            return inf;  // 无解
    }

    int cnt=0;
    for(int i=0;i<n;i++){
        for(int j=0;j<m;j++){
            cnt+=opt[i][j];  // 获取操作次数
        }
    }
    return cnt;
}

int main(){
    scanf("%d%d",&n,&m);
    for(int i=0;i<n;i++) {
        for(int j=0;j<m;j++){
            scanf("%d",&flip[i][j]);
        }
    }

    int flag=0; int as=inf;
    for(int i=(1<<m)-1;i>=0;i--){
        memset(opt,0,sizeof(opt));
        for(int j=m-1,k=0;j>=0;j--){
            opt[0][k++]= (i>>j)&1 ;// 第一行处理的方案 按照字典序减少得到
        }

      // for(int j=0;j<m;j++) printf("%d ",opt[0][j]); puts(""); // 可以去掉注释看字典序变化

       int res=solve();
        if(res!=inf){   // 首先有解
            flag=1;
            if(res<=as) {  // 次数相同时候,越靠近最后 字典序越小
                as=res;
                memcpy(ans,opt,sizeof(opt));
            }
        }
    }

    if(!flag) puts("IMPOSSIBLE");
    else {
        for(int i=0;i<n;i++){
            for(int j=0;j<m;j++){
                if(j != 0) putchar(' ');
                printf("%d",ans[i][j]);
                }
            puts("");
        }
    }
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值