poj 3614 Sunscreen(优先级队列+贪心)

9 篇文章 0 订阅
Sunscreen
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 8622 Accepted: 3029

Description

To avoid unsightly burns while tanning, each of the C (1 ≤ C ≤ 2500) cows must cover her hide with sunscreen when they're at the beach. Cow i has a minimum and maximum SPF rating (1 ≤ minSPFi ≤ 1,000; minSPFi ≤ maxSPFi ≤ 1,000) that will work. If the SPF rating is too low, the cow suffers sunburn; if the SPF rating is too high, the cow doesn't tan at all........

The cows have a picnic basket with L (1 ≤ L ≤ 2500) bottles of sunscreen lotion, each bottle i with an SPF rating SPFi(1 ≤ SPFi ≤ 1,000). Lotion bottle i can cover coveri cows with lotion. A cow may lotion from only one bottle.

What is the maximum number of cows that can protect themselves while tanning given the available lotions?

Input

* Line 1: Two space-separated integers: C and L
* Lines 2..C+1: Line i describes cow i's lotion requires with two integers: minSPFi and maxSPFi 
* Lines C+2..C+L+1: Line i+C+1 describes a sunscreen lotion bottle i with space-separated integers: SPFi and coveri

Output

A single line with an integer that is the maximum number of cows that can be protected while tanning

Sample Input

3 2
3 10
2 5
1 5
6 2
4 1

Sample Output

2
tips:选取最多的牛涂上防晒霜使其不被晒...题目中要求防晒霜必须在牛的最小值与最大值之间。
贪心选择:每次在防晒霜的可行解中选择牛的最大值最小的,这样才能保证更多的牛涂上防晒霜。
因此将防晒霜以及牛的最小值进行排序,将所有防晒霜大于最小值的牛的最大值入队,
使用优先级队列每次选取其中的最小值,如果防晒霜的值小于最大值,则ans++,同时cover-1;
 
#include<iostream>
#include<utility>
#include<cstring>
#include<queue>
#include<algorithm>
using namespace std;
typedef pair<int,int>pr;
pr cow[2555],scr[2555];
int c,l,ans;
int main()
{
	cin>>c>>l;
	for(int i=0;i<c;i++)cin>>cow[i].first>>cow[i].second;
	for(int i=0;i<l;i++)cin>>scr[i].first>>scr[i].second;
	
	sort(cow,cow+c);
	sort(scr,scr+l);
	priority_queue<int,vector<int>,greater<int> >q;
	int j=0;
	for(int i=0;i<l;i++)//枚举防晒霜 
	{
		while(j++<c&&scr[i].first>=cow[j].first)
			q.push(cow[j].second);
		while(!q.empty()&&scr[i].second)
		{
			int x=q.top();q.pop();
			if(scr[i].first<=x){
				ans++;
				scr[i].second--;
			}
		}
	}
	
	cout<<ans<<endl;
	
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值