poj 3468 Simple Problem with Integers(区间更新+懒惰标记)

 Simple Problem with Integers
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 109294 Accepted: 34031
Case Time Limit: 2000MS

Description

You have N integers, A1A2, ... , AN. You need to deal with two kinds of operations. One type of operation is to add some given number to each number in a given interval. The other is to ask for the sum of numbers in a given interval.

Input

The first line contains two numbers N and Q. 1 ≤ N,Q ≤ 100000.
The second line contains N numbers, the initial values of A1A2, ... , AN. -1000000000 ≤ Ai ≤ 1000000000.
Each of the next Q lines represents an operation.
"C a b c" means adding c to each of AaAa+1, ... , Ab. -10000 ≤ c ≤ 10000.
"Q a b" means querying the sum of AaAa+1, ... , Ab.

Output

You need to answer all Q commands in order. One answer in a line.

Sample Input

10 5
1 2 3 4 5 6 7 8 9 10
Q 4 4
Q 1 10
Q 2 4
C 3 6 3
Q 2 4

Sample Output

4
55
9
15

Hint

The sums may exceed the range of 32-bit integers.


tips:说下两个坑点吧.  

1.懒惰标记时应该是追加标记,而不是覆盖。

2.lazy的类型也应该是ll类型的,因为在pushdown的累加过程中可能超int(因为这个自己wa无数)

#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int maxn=110000;
#define ll long long
int n,q;
ll sum[maxn<<2];
ll lazy[maxn<<2];

void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}

void build(int rt,int l,int r)
{
	if(l==r){
		scanf("%lld",&sum[rt]);
		return;
	}
	int m=(l+r)>>1;
	build(rt<<1,l,m);
	build(rt<<1|1,m+1,r);
	pushup(rt);
}

void pushdown(int rt,int l,int r)
{
	if(lazy[rt]){
		lazy[rt<<1]+=lazy[rt];lazy[rt<<1|1]+=lazy[rt];
		int m=(l+r)>>1;
		sum[rt<<1]+=lazy[rt]*(m-l+1);
		sum[rt<<1|1]+=lazy[rt]*(r-m);
		lazy[rt]=0;
	}
}
void update(int x,int y,int z,int rt,int l,int r)
{
	if(x<=l&&y>=r){
		lazy[rt]+=z;
		sum[rt]+=(ll)z*(r-l+1);
		return;
	}
	pushdown(rt,l,r);
	int m=(l+r)>>1;
	if(x<=m)update(x,y,z,rt<<1,l,m);
	if(y>m)update(x,y,z,rt<<1|1,m+1,r);
	pushup(rt);
	
}

ll query(int x,int y,int rt,int l,int r)
{
	if(x<=l&&y>=r){
		return sum[rt];
	}
	pushdown(rt,l,r);
	ll ret=0;
	int m=(l+r)>>1;
	if(x<=m)ret+=query(x,y,rt<<1,l,m);
	if(y>m)ret+=query(x,y,rt<<1|1,m+1,r);
	return ret;
}
int main()
{
	while(~scanf("%d %d",&n,&q))
	{
		memset(sum,0,sizeof(sum));
		memset(lazy,0,sizeof(lazy));
	//	scanf("%d %d",&n,&q);
		build(1,1,n);
		char s[5];
		while(q--)
		{
			scanf("%s",s);
			if(s[0]=='Q'){
				int x,y;scanf("%d %d",&x,&y); 
				printf("%lld\n",query(x,y,1,1,n));	
			}
			else{
				int x,y,z;scanf("%d %d %d",&x,&y,&z);
				update(x,y,z,1,1,n);
			}
		}
		
	}
	
	return 0;
 } 




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值