Stars(线段树)

Stars
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 49231 Accepted: 21246

Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 

For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate. 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

Sample Input

5
1 1
5 1
7 1
3 3
5 5

Sample Output

1
2
1
1
0

Hint

This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

tips:每次做线段树都不能1A,做了半晚上这个题。
说下思路吧,就是求一个点 的 左下角有多少点。
因为题目是根据y的递增顺序输入的,所以我们只需要将x看成区间即可。因为y肯定是递增的。

线段树结点值代表:当前x的区间的点的 个数。
ans[i]=j;代表第i层的点的个数有j个。
对于i的求法,每当插入一个点,统计他前面的点的总个数;即是当前点所处的层数;

注意xy的最大值达到32000;意思叶子结点最多32000;线段树的结点最多是其4倍;
本boy就是因为数组开小了,想了半天才搞出来;希望以后做线段树的题目能 越来越顺手~

#include<iostream>
#include<cstring>
#include<cstdio> 
using namespace std;
const int maxn=32767;
const int mmax=33767;
int n;
int ans[maxn<<2];
int sum[maxn<<2];

void pushup(int rt)
{
	sum[rt]=sum[rt<<1]+sum[rt<<1|1];
}
int query(int rt,int l,int r,int ll,int rr)
{
	if(ll<=l&&rr>=r){
		return sum[rt];
	}
	int ret=0;
	int m=(l+r)>>1;
	if(ll<=m)ret+=query(rt<<1,l,m,ll,rr);
	if(rr>m)ret+=query(rt<<1|1,m+1,r,ll,rr);
	return ret;
}
void update(int rt,int l,int r,int x)
{
	if(l==r){
		sum[rt]++;
		return;
	}
	int m=(l+r)>>1;
	if(x<=m)update(rt<<1,l,m,x);
	else update(rt<<1|1,m+1,r,x);
	pushup(rt);
}
int main()
{
	cin>>n;
	for(int i=1;i<=n;i++)
	{
		int x,y;scanf("%d %d",&x,&y);
		ans[query(1,0,mmax,0,x)]++;
		update(1,0,mmax,x);
	}
	for(int i=0;i<n;i++)cout<<ans[i]<<endl; 
	
	
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
Gitee 是一个国内知名的代码托管平台,类似于国外的 GitHub,用户可以在上面创建仓库并进行代码托管。获取仓库的 stars 是评估该仓库受欢迎程度的一种方式。 要获取一个仓库的 stars 数量,首先需要登录 Gitee 平台,并找到该仓库的主页。在仓库主页的右上方有一个 "Star" 的按钮,点击该按钮即可为该仓库增加一个 star。同时,在该按钮的旁边还会显示当前该仓库的 stars 数量,用于了解该仓库的受欢迎程度。 除了手动点击按钮增加 stars,Gitee 还提供了 API 接口,可以通过编程的方式获取 stars 数量。使用 API 获取 stars 时,需要先获取该仓库的 ID 或者完整地址,并使用合法的 API 调用权限。然后通过 API 请求,可以获取到该仓库的 stars 数量,以便在其他应用程序中使用。 获取仓库的 stars 数量对于开发者来说具有重要意义,因为 stars 数量越多,代表有更多的人对该仓库感兴趣,并且可能意味着该仓库的代码质量较高。对于项目的维护者来说,高 stars 数量也意味着更多的社区支持和用户贡献,这将对项目的发展和推广都起到积极的作用。 总结来说,想要获取 Gitee 上一个仓库的 stars 数量,可以手动点击仓库主页上的 "Star" 按钮进行查看,也可以使用 API 来获取并在其他应用程序中使用。同时,高 stars 数量也是一个代码仓库受欢迎程度的重要指标。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值