描述
Click Here
当给定一个序列a[0],a[1],a[2],……,a[n-1]和一个整数K时,我们想找出,有多少个子序列满足这么一个条件:把当前子序列里面的所有元素乘起来恰好等于K。
输入:
多组测试数据。在输入文件的第一行有一个整数T(0< T <= 20),表示有T组数据。
接下来的2*T行,会给出每一组数据
每一组数据占两行,第一行包含两个整数n, K(1<=n<=1000,2<=K<=100000000)他们的含意已经在上面提到。
第二行包含a[0],a[1],a[2],…,a[n-1] (1<= a[i]<=K) 以一个空格分开。
所有输入均为整数。
输出:
对于每一个数据,将答案对1000000007取余之后输出即可。
输入样例:
2
3 3
1 1 3
3 6
2 3 6
输出样例:
4
2
第一组输入样例解释:
我们可以选择【3】或者【1(第一个1),3】或者【1(第二个1),3】或者【1,1,3】
题解
我太垃圾了。。。。。
map<long long,long long>dp[i]存储满足“子序列里面的所有元素乘积为i的个数”,最后的结果返回dp[K]【只统计能被K整除的i】
当来了一个a[i],将a[i]和dp[]中所有的元素相乘,如果乘积能被K整除,则将乘积加到map<long long,long long>dp[]中。
map这个结构就很方便了。
代码
#include <iostream>
#include<stdio.h>
#include<map>
#include<algorithm>
#define maxn 1005
typedef long long ll;
using namespace std;
const ll mod = 1e9 + 7;
ll a[maxn];
int main(){
int T,n;
ll K;
scanf("%d",&T);
while(T--){
scanf("%d",&n);
scanf("%lld",&K);
map<ll,ll>dp;
map<ll,ll>dp_;
map<ll, ll> :: iterator iter;
for(int i=0; i<n; i++){
scanf("%lld",&a[i]);
if(K%a[i]==0){
dp_=dp;
dp[a[i]]+=1;
for(iter = dp_.begin(); iter != dp_.end(); iter++){
ll x = iter -> first;
if(K % (x * a[i]) == 0){
dp[x * a[i]] += iter -> second;
dp[x * a[i]] %= mod;
}
}
}
}
printf("%lld\n",dp[K]);
}
return 0;
}