B - !সহজ ~কঠিন -- (n个数最小公倍数,gcd)

B - !সহজ ~কঠিন
Time Limit:1000MS     Memory Limit:65536KB     64bit IO Format:%lld & %llu

Description


Find the least common multiple (LCM) of given n integers.

Input

na1a2 ... an

n is given in the first line. Then, n integers are given in the second line.

Output

Print the least common multiple of the given integers in a line.

Constraints

  • 2 ≤ n ≤ 10
  • 1 ≤ ai ≤ 1000
  • Product of given integers ai(i = 1, 2, ... n) does not exceed 231-1

Sample Input 1

3
3 4 6

Sample Output 1

12

Sample Input 2

4
1 2 3 5

Sample Output 2

30
#include <stdio.h>
int gcd(int a,int b){
	if(b==0)
		return a;
	return gcd(b,a%b);
}
int main(){
	int a[1005];
	int i,n,sum;
	scanf("%d",&n);
	for(i=1;i<=n;i++)
		scanf("%d",&a[i]);
	sum=1;
	for(i=1;i<=n;i++){
		sum=a[i]/gcd(sum,a[i])*sum;
	}
	printf("%d\n",sum);
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值