[POJ - 3061] Subsequence(尺取法)

17 篇文章 0 订阅
10 篇文章 0 订阅

题目传送门:Here
来源:Southeastern Europe 2006
Time Limit: 1000MS Memory Limit: 65536K

Description

A sequence of N positive integers (10 < N < 100 000), each of them
less than or equal 10000, and a positive integer S (S < 100 000 000)
are given. Write a program to find the minimal length of the
subsequence of consecutive elements of the sequence, the sum of which
is greater than or equal to S.
现有一段长度为10<N<100000的整数序列,每一个整数都小于等于10000。给定一个S<100000000,请你找到一段最小长度的连续子序列,使得子序列的和大于或等于S。

Input

The first line is the number of test cases. For each test case the
program has to read the numbers N and S, separated by an interval,
from the first line. The numbers of the sequence are given in the
second line of the test case, separated by intervals. The input will
finish with the end of file.
第一行是测试个数。然后每个测试第一行读入N和S(空格间隔),第二行是整数序列(空格间隔)

Output

For each the case the program has to print the result on separate line
of the output file.if no answer, print 0.
每一个测试输出独立一行的结果,如果没有答案,输出0。

Sample Input

2
10 15
5 1 3 5 10 7 4 9 2 8
5 11
1 2 3 4 5

Sample Output

2
3

解析
此题要寻找最小长度的连续子序列和最大值(尺取法)
(尺取法:不满足条件右端点向右移动,满足条件左端点向右移动,如同尺子移动得此名)

C语言代码

#include <stdio.h>
int a[100005];
int main(void)
{
    int T;
    scanf("%d",&T);	//读入测试案例的个数
    while(T--)
    {
        int num,S;
        scanf("%d%d",&num,&S);
        int min=num,sum=0;
        int i,j;
        for(i=0;i<num;i++)
            scanf("%d",&a[i]);	//初始化数据
        for(i=0,j=0;;)			//尺取代码
        {
            while(i<num&&sum<S)
                sum+=a[i++];
            if(sum<S)break;
            if(min>(i-j))
                min=i-j;
            sum-=a[j++];
        }
        if(min>=num&&sum<S)	//判断答案是否合法
            min=0;
        printf("%d\n",min);
    }
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值