hdoj2588 GCD欧拉函数

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1321    Accepted Submission(s): 598


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:   1695  1787  3501  2824  2582 
题意:是让求x从1到n,gcb(x,n)>=m个数
由于gcb(a*b,a*c)=a,则b和c互质,假设n>=c*b,gcb(c*b,n)=c,c>=m,这道题就变成求b的欧拉个数.由于数据量太大需要优化。
#include<stdio.h>
//求小于x与x互质的个数 
int euler(int x)
{
	int s=x;
	for(int i=2;i*i<=x;i++)
	{
		if(x%i==0)
		{
			s=s/i*(i-1);
			while(x%i==0)
			x/=i;
		}
	}
	if(x>1)s=s/x*(x-1);
	return s;
}
int main()
{
	int t,i,ans,n,m;
	scanf("%d",&t);
	while(t--)
	{
		ans=0;
		scanf("%d%d",&n,&m);
		for(i=1;i*i<=n;i++)//优化代码 
		{
			if(n%i==0)
			{
				if(i>=m)
				{
					ans+=euler(n/i);
				}
				if(n/i>=m&&i*i!=n)ans+=euler(i);
			}
			
		}
		printf("%d\n",ans);
	}
	return 0;
}

 
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值