hdoj 2588 GCD

GCD

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1207    Accepted Submission(s): 548


Problem Description
The greatest common divisor GCD(a,b) of two positive integers a and b,sometimes written (a,b),is the largest divisor common to a and b,For example,(1,2)=1,(12,18)=6.
(a,b) can be easily found by the Euclidean algorithm. Now Carp is considering a little more difficult problem:
Given integers N and M, how many integer X satisfies 1<=X<=N and (X,N)>=M.
 

Input
The first line of input is an integer T(T<=100) representing the number of test cases. The following T lines each contains two numbers N and M (2<=N<=1000000000, 1<=M<=N), representing a test case.
 

Output
For each test case,output the answer on a single line.
 

Sample Input
  
  
3 1 1 10 2 10000 72
 

Sample Output
  
  
1 6 260
 

Source


#include <cstdio>
#include <vector>
#define BUG puts("bug is here!");

using namespace std;
vector<int> V;

int Eular(int x) {
	int ans = x;

	for (int i = 2; i * i <= x; ++i) {
		if (x % i == 0) {
			ans -= ans / i;
			while (x % i == 0)
				x /= i;
		}
	}

	if (x > 1)
		ans -= ans / x;

	return ans;
}

void Init(int x) {
	V.clear();
	int i;

	for (i = 1; i * i < x; ++i)
		if (x % i == 0) {
			V.push_back(i);
			V.push_back(x / i);
		}

	if (i * i == x)
		V.push_back(i);
}

int main() {
	int t;
	scanf("%d", &t);

	while (t--) {
		int n, m;
		scanf("%d%d", &n, &m);
		Init(n);
		int ans = 0;

		for (int i = 0; i < V.size(); ++i) {
			if (V[i] >= m) 
				ans += Eular(n / V[i]);
		}

		printf("%d\n", ans);
	}

	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值