HDU 1002 A + B Problem II

Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
  
  
2 1 2 112233445566778899 998877665544332211
 

Sample Output
  
  
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110

虽然不是很难,但因为格式问题WA了好几次,醉醉的。

我加了注释,应该不难理解,上代码:

#include<stdio.h>
int main()
{
	int n,i,j,k,s1[1010],s2[1010];
	char c1[1010],c2[1010];
	scanf("%d",&n);
	for(k = 1; k <= n;k ++)
	{
		memset(s1,0,1010*sizeof(int));//数组全部置0
		memset(s2,0,1010*sizeof(int));//数组全部置0
		scanf("%s%s",c1,c2);
		j = 0;
		for(i = strlen(c1)-1; i >= 0; i--)
		{
			s1[j++] = c1[i]-'0';//将第一个数逐位copy
		}
		j = 0;
		for(i = strlen(c2)-1; i >= 0; i--)
		{
			s2[j++] = c2[i]-'0';//将第二个数逐位copy
		}
		for(i = 0; i < 1010; i++)//两个数组即两个数逐位相加,若位相加结果大于等于10,减10进1位
		{
			s1[i] += s2[i];
			if(s1[i] > 9)
			{
				s1[i] -= 10;
				s1[i+1] ++;
			}
		}
		printf("Case %d:\n%s + %s = ",k,c1,c2);
		for(i = 1009; i >= 0; i--)//取第一位不为0的数的角标
		{
			if(s1[i])
				break;
		}
		for(j = i;j >= 0;j --)//依次输出结果
		{
			printf("%d",s1[j]);
		}
		printf("\n");
		if(k != n)
			printf("\n");
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值