山东省第七届ACM省赛------Memory Leak

Memory Leak

Time Limit: 2000MS Memory limit: 131072K

题目描述

Memory Leak is a well-known kind of bug in C/C++. When a string is longer than expected, it will visit the memory of next array which will cause the issue and leak some information. You can see a simple example bellow:

As we see, if the length of the input string is equal to or larger than the limit length of array, the extra part won’t be stored and the information of next array will be leaked out while outputting. The output will stop until a ‘\0’ character (the symbol of end of a string) is found. In this problem, there will never be unexpected end of the program and the last array won’t leak other information.

Source code given as follow:

Now a simpler source code will be given. What will the output be?

输入

 Multiple test cases, the first line is an integer T (T <= 20), indicating the number of test cases.

The first line of each test case contains a non-empty string, the definition of strings, formatted as “char s1[s1_len], s2[s2_len]...;”. “char ” is the type of the array which will never change. s1, s2... is the name of the array. s1_len, s2_len... is the length limit. If nothing goes wrong, the array should be able to store the input string and a ‘\0’. The definitions of different arrays will be separated by a comma and a space. The length limits are positive and the Sum of length limit will be less than 10000.

Then, there will be several lines of string which consists two or three parts.

The first part is “gets” or “cout”, the second part will a string s, indicates the name of the array. s will contains only lower case letters and number digits and start with letters. s will be different in one case. If the first part is “gets”, then there will be the third part, a string which should be input into array s, the length of input string will be less than 1000 and contains only visible ASCII characters. “gets” operation will rewrite the array no matter what was in the array before and add a ‘\0’ after the string. Different parts are separated by a space.

Case ends with “return 0;”

The whole input file is less than 10MB.

输出

 For each “cout”, you should output a line contains what will actually output, which means you should consider the issue of memory leak. If the requested array is empty, you should output an empty line.

示例输入

3
char a[5], b[5], c[5];
gets a C++
gets b Hello, world!
gets c guys
cout a
cout b
cout c
return 0;
char a[5];
cout a
gets a 233
gets a 2333
cout a
gets a 12345
cout a
return 0;
char str1[7], str2[2], str3[5];
gets str1 welcome
gets str2 to
gets str3 Shandong
cout str1
return 0;

示例输出

C++
Helloguys
guys
2333
12345
welcometoShand

来源

  “浪潮杯”山东省第七届ACM大学生程序设计竞赛

题意

一道不算很难的模拟题吧!输入的是字符串,模拟操作,定义数组,输入到数组,然后输出,其实呢!主要考察的是内存泄漏的问题,也就是一个数组的最后没有‘\0’,然后输出的时候会访问到下一段内存空间中!

AC代码:(别人的)
#include <bits/stdc++.h>
using namespace std;
struct node
{
    int l;
    int r;
} e[11111];
int top;
char s[11111];
char c[11111][1111];
char op[11111];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(s,0,sizeof(s));
        int pos = 0;
        top = 0;
        scanf("%s",op);
        while(true)
        {
            scanf("%s",op);
            int len = strlen(op);
            int num = 0,i = 0;
            for(i = 0; i < len; i++)
            {
                if(op[i] != '[')c[top][i] = op[i];
                else break;
            }
            c[top][i] = '\0';
            for(i++ ; i < len; i++)
            {
                if(op[i] == ']') break;
                num = num * 10 + op[i] -'0';
            }
            e[top].l = pos;
            e[top].r = pos+num;
            pos+=num;
            top++;
            char ss = getchar();
            if(ss == '\n') break;
        }
        while(1)
        {
            scanf("%s",op);
            if(op[0] == 'r')
            {
                scanf("%s",op);
                break;
            }
            if(op[0] == 'c')
            {
                scanf("%s", op);
                for(int i = 0; i < top; i++)
                {
                    if(strcmp(op,c[i]) == 0)
                    {
                        for(int j = e[i].l ; j < pos; j++)
                        {
                            if(s[j] == '\0') break;
                            printf("%c",s[j]);
                        }
                        printf("\n");
                        break;
                    }
                }
            }
            else if(op[0] == 'g')
            {
                scanf("%s",op);
                for(int i = 0 ; i < top; i++)
                {
                    if(strcmp(op,c[i]) == 0)
                    {
                        gets(op);
                        int len = strlen(op);
                        int k = 1,j;
                        for( j = e[i].l ; j < e[i].r && k < len; j++, k++)
                            s[j] = op[k];
                        if(j < e[i].r)
                            s[j] = '\0';
                        break;
                    }
                }
            }
        }
    }
    return 0;
}

TLE代码:(自己的)
#include"stdio.h"
#include"string.h"
#include<iostream>
using namespace std;
#include<map>
char data[1000005];
map<string,int>k;
map<string,int>ss;
int main()
{
    int N;
    cin>>N;
    while(N--)
    {
        k.clear();
        ss.clear();
        memset(data,0,sizeof(data));
        string start;
        int ci=0;
        while(cin>>start)
        {
            if(start=="char")
            {
                char c[1005]= {0};
                int size=0;
                char jud=0;
                while(~scanf("%*[ ]%[^[][%d]%c",c,&size,&jud))
                {
                    k[c]=ci;
                    ss[c]=size;
                    ci+=size;
                    if(jud==';')break;
                }
            }
            else if(start=="gets")
            {
                string value;
                cin>>value;
                scanf("%*[ ]");
                gets(data+k[value]);
                data[k[value]+ss[value]]=0;
                memset(data+k[value]+ss[value],0,sizeof(data+k[value]+ss[value]));
                for(int i=k[value]+ss[value]; i<=1000005; i++)
                    data[i]=0;
//                cout<<"/"<<endl;
//                for(int i=0;i<20;i++)
//                    printf(i!=19?"%c":"%c\n",data[i]);
            }
            else if(start=="cout")
            {
                string va;
                cin>>va;
                if(ss[va])puts(data+k[va]);
//                for(int i=k[va];i<k[va]+(int)strlen(data+k[va])&&i<ci;i++)
//                    putchar(data[i]);
//                printf("\n");
            }
            else if(start=="return")
            {
                fflush(stdin);
                break;
            }
        }
    }
    return 0;
}

伤心(;′⌒`)~
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值