ACM第六届山东省赛 C-Game

ACM第六届山东省赛 C-Game

Time Limit: 2000 ms   Memory Limit: 65536 KiB

Description
One day, zbybr is playing a game with blankcqk, here are the rules of the game:
There is a circle of N stones, zbybr and blankcqk take turns taking the stones.
Each time, one player can choose to take one stone or take two adjacent stones.
You should notice that if there are 4 stones, and zbybr takes the 2nd, the 1st and 3rd stones are still not adjacent.
The winner is the one who takes the last stone.
Now, the game begins and zbybr moves first.
If both of them will play with the best strategy, can you tell me who will win the game?

Input
The first line of input contains an integer T, indicating the number of test cases (T≈100000).
For each case, there is a positive integer N (N ≤ 10^18).

Output
Output the name of the winner.

Sample Input
2
1
2

Sample Output
zbybr
zbybr

题目链接:http://acm.sdut.edu.cn/onlinejudge2/index.php/Home/Index/problemdetail/pid/3560.html

本题是一道环形博弈的题目
环形博弈是一个很简单的博弈,n个石子围成一个环,每次取一个或者取相邻的2个,若石子数小于等于2则先手赢,否则后手赢。

参考代码

#include <stdio.h>
int main(void)
{
    long long t, n;
    int i, j, k;
    scanf("%lld", &t);
    while(t--){
        scanf("%lld", &n);
        if(n <= 2)
            printf("zbybr\n");
        else
            printf("blankcqk\n");
    }
    return 0;
}
  • 3
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值