HDU 1686 Oulipo

题目链接:HDU1686

Oulipo

Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 9398    Accepted Submission(s): 3758


Problem Description
The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter 'e'. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T's is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {'A', 'B', 'C', …, 'Z'} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

 

Input
The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:

One line with the word W, a string over {'A', 'B', 'C', …, 'Z'}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {'A', 'B', 'C', …, 'Z'}, with |W| ≤ |T| ≤ 1,000,000.
 

Output
For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

 

Sample Input
  
  
3 BAPC BAPC AZA AZAZAZA VERDI AVERDXIVYERDIAN
 

Sample Output
  
  
1 3 0
 


题意:问模式串在原串中出现了几次,重叠的也要算。

题目分析:KMP模板,在计数时每次遇到模式串匹配完都要返回末位的next值继续匹配。


//
//  main.cpp
//  HDU1686(2)
//
//  Created by teddywang on 16/4/22.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1000010],t[10010];
int nexts[100010];
int lens,lent,T;

void getnext()
{
    int i=0,j=-1;
    nexts[0]=-1;
    while(i<lent)
    {
        if(j==-1||t[i]==t[j])
        {
            if(t[++i]==t[++j])
                nexts[i]=nexts[j];
            else nexts[i]=j;
        }
        else j=nexts[j];
    }
}

int kmp()
{
    int ans=0;
    int i=0,j=0;
    while(i<lens)
    {
        if(j==-1||s[i]==t[j])
        {
            ++i;++j;
            if(j==lent)
            {
                ans++;
                j=nexts[j];
            }
        }
        else j=nexts[j];
    }
    return ans;
}

int main()
{
    cin>>T;
    while(T--)
    {
        memset(s,0,sizeof(s));
        memset(t,0,sizeof(t));
        scanf("%s",t);
        scanf("%s",s);
        lens=strlen(s);lent=strlen(t);
        getnext();
        cout<<kmp()<<endl;
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值