POJ2886 Who Gets the Most Candies?

20 篇文章 0 订阅

题目链接:POJ2886

Who Gets the Most Candies?
Time Limit: 5000MS Memory Limit: 131072K
Total Submissions: 12885 Accepted: 4017
Case Time Limit: 2000MS

Description

N children are sitting in a circle to play a game.

The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (A)-th child to the right.

The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?

Input

There are several test cases in the input. Each test case starts with two integers  N (0 <  N  ≤ 500,000) and K (1 ≤ K ≤ N) on the first line. The next N lines contains the names of the children (consisting of at most 10 letters) and the integers (non-zero with magnitudes within 108) on their cards in increasing order of the children’s numbers, a name and an integer separated by a single space in a line with no leading or trailing spaces.

Output

Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.

Sample Input

4 2,
Tom 2
Jack 4
Mary -1
Sam 1

Sample Output

Sam 3
题意:一堆小孩围成圈玩游戏。每个小孩手上有卡片从第k个小孩出列,他手上的卡片k是正整数就顺时针数到第k个人出列,负数就逆时针,每个出列的小孩可以得到它们出列顺序的那个数字的所有因子的个数。问哪个小孩得到的糖最多。
题目分析:要不是学线段树专题还真没看出来是线段树的题。用sum数组来存每个跟节点的区间还剩几个点。反素数打表来找因子最多的那一项。在出人的时候,这里用相对坐标的思想,当第k个出去的时候k+1变为k,如果是+m,那下一个就是k+m-1,如果是-m下一个就是k-m,注意负数和取模的情况。
线段树用来查人,判断k在根左面还是右面,注意右面的情况递归调用时应为k-sum[rt<<1],代表已经排除掉左面的点,因为update(k,l,r,rt)代表找到在l右侧k个的点。
//
//  main.cpp
//  POJ2886(1
//
//  Created by teddywang on 16/5/17.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 500010
const int antiprime[]={1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,
    1260,1680,2520,5040,7560,10080,15120,20160,25200,
    27720,45360,50400,55440,83160,110880,166320,221760,
    277200,332640,498960,554400,665280
};

const int factorNum[]={1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,
    64,72,80,84,90,96,100,108,120,128,144,160,168,180,
    192,200,216,224
};

int sum[maxn<<2];
struct node{
    int nexts;
    char name[20];
}child[maxn];

void build (int l,int r,int rt)
{
    sum[rt]=r-l+1;
    if(l==r) return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}

int update(int k,int l,int r,int rt)
{
    sum[rt]--;
    if(l==r) return r;
    int m=(l+r)>>1;
    if(k<=sum[rt<<1]) return update(k,lson);
    else return update(k-sum[rt<<1],rson);
}

int main()
{
    int n,k,&mod=sum[1];
    while(~scanf("%d%d",&n,&k))
    {
        for(int i=1;i<=n;i++)
            scanf("%s%d",child[i].name,&child[i].nexts);
        build(1,n,1);
        int num=0;
        while(num<35&&antiprime[num]<=n)
            num++;
        num--;
        int pos=0;
        child[pos].nexts=0;
        for(int i=1;i<=antiprime[num];i++)
        {
            if(child[pos].nexts>0)
                k=((k+child[pos].nexts-2)%mod+mod)%mod+1;
            else k=((k+child[pos].nexts-1)%mod+mod)%mod+1;
            pos=update(k,1,n,1);
        }
        printf("%s %d\n",child[pos].name,factorNum[num]);
    }
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值