题目链接:POJ2886
Time Limit: 5000MS | Memory Limit: 131072K | |
Total Submissions: 12885 | Accepted: 4017 | |
Case Time Limit: 2000MS |
Description
N children are sitting in a circle to play a game.
The children are numbered from 1 to N in clockwise order. Each of them has a card with a non-zero integer on it in his/her hand. The game starts from the K-th child, who tells all the others the integer on his card and jumps out of the circle. The integer on his card tells the next child to jump out. Let A denote the integer. If A is positive, the next child will be the A-th child to the left. If A is negative, the next child will be the (−A)-th child to the right.
The game lasts until all children have jumped out of the circle. During the game, the p-th child jumping out will get F(p) candies where F(p) is the number of positive integers that perfectly divide p. Who gets the most candies?
Input
Output
Output one line for each test case containing the name of the luckiest child and the number of candies he/she gets. If ties occur, always choose the child who jumps out of the circle first.
Sample Input
4 2, Tom 2 Jack 4 Mary -1 Sam 1
Sample Output
Sam 3
//
// main.cpp
// POJ2886(1
//
// Created by teddywang on 16/5/17.
// Copyright © 2016年 teddywang. All rights reserved.
//
#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
#define maxn 500010
const int antiprime[]={1,2,4,6,12,24,36,48,60,120,180,240,360,720,840,
1260,1680,2520,5040,7560,10080,15120,20160,25200,
27720,45360,50400,55440,83160,110880,166320,221760,
277200,332640,498960,554400,665280
};
const int factorNum[]={1,2,3,4,6,8,9,10,12,16,18,20,24,30,32,36,40,48,60,
64,72,80,84,90,96,100,108,120,128,144,160,168,180,
192,200,216,224
};
int sum[maxn<<2];
struct node{
int nexts;
char name[20];
}child[maxn];
void build (int l,int r,int rt)
{
sum[rt]=r-l+1;
if(l==r) return ;
int m=(l+r)>>1;
build(lson);
build(rson);
}
int update(int k,int l,int r,int rt)
{
sum[rt]--;
if(l==r) return r;
int m=(l+r)>>1;
if(k<=sum[rt<<1]) return update(k,lson);
else return update(k-sum[rt<<1],rson);
}
int main()
{
int n,k,&mod=sum[1];
while(~scanf("%d%d",&n,&k))
{
for(int i=1;i<=n;i++)
scanf("%s%d",child[i].name,&child[i].nexts);
build(1,n,1);
int num=0;
while(num<35&&antiprime[num]<=n)
num++;
num--;
int pos=0;
child[pos].nexts=0;
for(int i=1;i<=antiprime[num];i++)
{
if(child[pos].nexts>0)
k=((k+child[pos].nexts-2)%mod+mod)%mod+1;
else k=((k+child[pos].nexts-1)%mod+mod)%mod+1;
pos=update(k,1,n,1);
}
printf("%s %d\n",child[pos].name,factorNum[num]);
}
}