HDU 2795 Billboard

20 篇文章 0 订阅

题目链接:HDU2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 17773    Accepted Submission(s): 7477


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that's why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can't be put on the billboard, output "-1" for this announcement.
 

Sample Input
  
  
3 5 5 2 4 3 3 3
 

Sample Output
  
  
1 2 1 3 -1
 

题意:给出一块h*w的板子,要在上面贴广告,广告统一宽度1,长度为wi,从1到h贴,只要当前行能放得下就放在当前行,如果整个板子也放不下了就输出-1,否则输出放置的位置。

题目分析:当板子的高度比广告数多时,多出来的那些就没有什么意义,可以直接裁掉。安置和查询同步进行,数组s[i]储存跟节点为i的位置下每行最大的剩余空间,用update函数更新s的值,查询操作用query函数。

//
//  main.cpp
//  HDU2795
//
//  Created by teddywang on 16/5/4.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
#define lson l,m,rt<<1
#define rson m+1,r,rt<<1|1
using namespace std;
int m,n,t;
int s[200030<<2];

void update(int rt)
{
    s[rt]=max(s[rt<<1],s[rt<<1|1]);
}

void build(int l,int r,int rt)
{
    s[rt]=n;
    if(l==r)
        return ;
    int m=(l+r)>>1;
    build(lson);
    build(rson);
}

int query(int w,int l,int r,int rt)
{
    if(l==r)
    {
        s[rt]-=w;
        return l;
    }
    int m=(l+r)>>1;
    int ans=0;
    if(s[rt<<1]>=w)ans=query(w,lson);
    else ans=query(w,rson);
    update(rt);
    return ans;
}

int main()
{
    while(cin>>m>>n>>t)
    {
        if(m>t) m=t;
        build(1,m,1);
        for(int i=0;i<t;i++)
        {
            int w;
            scanf("%d",&w);
            if(s[1]<w) printf("-1\n");
            else printf("%d\n",query(w,1,m,1));
        }
    }
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值