HDU4763 Theme Section

题目链接:HDU4763

Theme Section

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2787    Accepted Submission(s): 1285


Problem Description
It's time for music! A lot of popular musicians are invited to join us in the music festival. Each of them will play one of their representative songs. To make the programs more interesting and challenging, the hosts are going to add some constraints to the rhythm of the songs, i.e., each song is required to have a 'theme section'. The theme section shall be played at the beginning, the middle, and the end of each song. More specifically, given a theme section E, the song will be in the format of 'EAEBE', where section A and section B could have arbitrary number of notes. Note that there are 26 types of notes, denoted by lower case letters 'a' - 'z'.

To get well prepared for the festival, the hosts want to know the maximum possible length of the theme section of each song. Can you help us?
 

Input
The integer N in the first line denotes the total number of songs in the festival. Each of the following N lines consists of one string, indicating the notes of the i-th (1 <= i <= N) song. The length of the string will not exceed 10^6.
 

Output
There will be N lines in the output, where the i-th line denotes the maximum possible length of the theme section of the i-th song.
 

Sample Input
  
  
5 xy abc aaa aaaaba aaxoaaaaa
 

Sample Output
  
  
0 0 1 1 2
 

题意:求最长的子串,同时在前缀后缀和中间出现,要求不能有重叠。

题目分析:kmp求next数组,然后依次向前求最长的公共前后缀,每求出来一个就扔到母串s中进行kmp匹配。注意母串这时要掐头去尾(字面意思),因为每次都找最大的匹配,所以一旦匹配成功答案就出来了。最后答案也出不来就输出0。

//
//  main.cpp
//  HDU4763(1
//
//  Created by teddywang on 16/6/7.
//  Copyright © 2016年 teddywang. All rights reserved.
//

#include <iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
char s[1111111];
int nexts[1111111];
int len,n;

void getnexts(char *s)
{
    int i=0,j=-1;
    nexts[0]=-1;
    while(i<len)
    {
        if(s[i]==s[j]||j==-1)
        {
            nexts[++i]=++j;
            if(nexts[i]>len/2)
                nexts[i]=len/2;
        }
        else j=nexts[j];
    }
}

int kmp(char *s,char *t,int ls,int lt)
{
    int i=0,j=0;
    while(i<ls&&j<lt)
    {
        if(s[i]==t[j]||j==-1)
        {
            i++;j++;
            if(j==lt)return 1;
        }
        else j=nexts[j];
    }
    return 0;
}

int main()
{
    cin>>n;
    while(n--)
    {
        scanf("%s",s);
        len=strlen(s);
        getnexts(s);
        int buf=nexts[len];
        while(buf!=0)
        {
            if(kmp(s+buf,s,len-2*buf,buf))
            {
                cout<<buf<<endl;
                break;
            }
            buf=nexts[buf];
        }
        if(buf==0)
        {
            cout<<0<<endl;
        }
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值