HDOJ1021

【原题】


Fibonacci Again

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 61881    Accepted Submission(s): 28892


Problem Description
There are another kind of Fibonacci numbers: F(0) = 7, F(1) = 11, F(n) = F(n-1) + F(n-2) (n>=2).
 

Input
Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000).
 

Output
Print the word "yes" if 3 divide evenly into F(n).

Print the word "no" if not.
 

Sample Input
  
  
0 1 2 3 4 5
 

Sample Output
  
  
no no yes no no no
 


这个题,根据找规律
F(0)=7,F(1)=11, F(n)= F(n-1)+ F(n-2),继续写几个
F(2)=18, F(3)=29,F(4)=47,F(5)=76,F(6)=123,F(7)=199,F(8)=322,…,
但是把F(n)算出来的意义不大,反而会超出内存??
因为题目关注的是F(n)能否被3整除,也就是说,我们需要关注的是F(n)%3,
继续算一下F(n)%3,得到如下序列,1, 2, 0, 2, 2, 1, 0, 1, 1, 2…发现了循环。
循环为8个一循环。

【代码】

#include<iostream>
using namespace std;
int main()
{
int n;
while(cin>>n)
{
if(n%8==2||n%8==6)
cout<<"yes"<<endl;
else
cout<<"no"<<endl;
}
return 0;
}

【经验】

1.做题不能上来就做,要动脑子。有关数学的在编程中也很重要啊,会简化运算。
2.做题的时候换个思路就会迎刃而解。
  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值