HDOJ 5311-Hidden String【深搜】

Hidden String

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 1677    Accepted Submission(s): 589


Problem Description
Today is the 1st anniversary of BestCoder. Soda, the contest manager, gets a string  s  of length  n . He wants to find three nonoverlapping substrings  s[l1..r1] s[l2..r2] s[l3..r3]  that:

1.  1l1r1<l2r2<l3r3n

2. The concatenation of  s[l1..r1] s[l2..r2] s[l3..r3]  is "anniversary".
 

Input
There are multiple test cases. The first line of input contains an integer  T   (1T100) , indicating the number of test cases. For each test case:

There's a line containing a string  s   (1|s|100)  consisting of lowercase English letters.
 

Output
For each test case, output "YES" (without the quotes) if Soda can find such thress substrings, otherwise output "NO" (without the quotes).
 

Sample Input
  
  
2 annivddfdersewwefary nniversarya
 

Sample Output
  
  
YES NO
 
解题思路
因为这个题中长度比较小可以暴力搞一下,利用深搜写在判断里判断是否满足段数大于三,然后继续深搜。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int len,len1;
char map[100000];
char moxing[20]="anniversary";
bool f(int x,int y,int ci)
{
	int i;
	if(ci<=3&&y>=len1)
	{
		return true;
	}
	else if(ci>3)
	{
		return false;
	}
	for(i=x;i<len;i++)
	{
		int wc,wcnm;
		wc=i,wcnm=y;
		while(wc<len&&wcnm<len1&&map[wc]==moxing[wcnm])
		{
			wc++;
			wcnm++;
		}
		if(wc>i&&f(wc,wcnm,ci+1))
		{
			return true;
		}	
	}
	return false;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%s",map);
		len=strlen(map);
		len1=strlen(moxing);
		bool cnm=f(0,0,0);
		if(cnm==true)
		printf("YES");
		else
		printf("NO");
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值