UESTC 1269-ZhangYu Speech

ZhangYu Speech

Edit

Time Limit: 3000/1000MS (Java/Others)     Memory Limit: 65535/65535KB (Java/Others)

SubmitStatus

as we all know, ZhangYu(Octopus vulgaris) brother has a very famous speech - "Keep some distance from me". ZhangYu brother is so rich that everyone want to contact he, and scfkcf is one of them. One day , ZhangYu brother agreed with scfkcf to contact him if scfkcf could beat him. There are n  digits(lets give them indices from 1  to n  and name them a 1 ,a 2 ...a N  ) and some queries.

for each query:

  1. ZhangYu brother choose an index x  from 1  to n .
  2. For all indices y  ( y  < x ) calculate the difference b y =a x −a y  .
  3. Then ZhangYu brother calculate B 1   ,the sum of all by which are greater than 0  , and scfkcf calculate B 2   , the sum of all by which are less than 0 .

if B 1 >|B 2 |  , ZhangYu brother won and did not agree with scfkcf to contact him; else if B 1   is equals to |B 2 |  , ZhangYu brother would ignore the result; else if B 1   < |B 2 |  , ZhangYu brother lost and agreed with scfkcf to contact him.

Input

The first line contains two integers n , m  (1≤n,m≤100000)  denoting the number of digits and number of queries. The second line contains n  digits (without spaces) a 1 ,a 2 ,...,a n  .(0≤a i ≤9)  Each of next m  lines contains single integer x  (1≤x≤n)  denoting the index for current query.

Output

For each of m  queries print "Keep some distance from me" if ZhangYu won, else print "Next time" if ZhangYu brother ignored the result, else print "I agree" if ZhangYu brother lost in a line - answer of the query.

Sample input and output

Sample InputSample Output
10 3
0324152397
1
4
7
Next time
Keep some distance from me
I agree

Hint

It's better to use "scanf" instead of "cin" in your code.

Source

第七届ACM趣味程序设计竞赛第四场(正式赛) 

题目大意:
给出有n个数字的字符串,m表示有多少个比赛回合,给出一个x则会就是第几个数,用这个数将他前面的数都减一遍,当差大于零的时候加到b1上,当小于零时加到b2上,最后都取绝对值,比较b1和b2的大小。
这个题主要注意超时,事先可以化简这个式子,得到公式,就是(x-1)*(map[x-1]-'0')-前x-1项和。所以只需要在运算前保留一下各个位置的前几项和就可以节约很多时间。

#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
char map[10000000];
int wo6[1000000],wo6defeiqi[1000000];
int main()
{
	int n,m;
	while(scanf("%d%d",&n,&m)!=EOF)
	{
		scanf("%s",map);
		int i,j;
		for(i=1;i<=n;i++)
		{
			wo6[i]=map[i-1]-'0';
		}
		for(i=1;i<=n;i++)
		{
			wo6defeiqi[i]=wo6[i]+wo6defeiqi[i-1];
		}
		while(m--)
		{
			int axiba;
			int xx;
			scanf("%d",&xx);
			axiba=(xx)*(map[xx-1]-'0')-wo6defeiqi[xx];
			if(axiba>0)
			printf("Keep some distance from me\n");
			else if(axiba==0)
			printf("Next time\n");
			else if(axiba<0)
			printf("I agree\n");
		}
	}
	return 0;
}

 

互联网络程序设计是指在互联网上进行程序开发和设计的过程。UESTC则是我国的一所著名高校——电子科技大学。 互联网络程序设计 uestc包含了两个主要的方面:互联网络和程序设计。互联网络是指将多个计算机网络通过通信链路互相连接起来,实现信息共享和资源共享的网络系统。程序设计是指根据需求和目标,通过编写代码和设计算法,实现计算机程序的过程。 互联网络程序设计 uestc的学习内容主要包括以下几个方面: 1. 网络知识:学习互联网络的基本概念、原理和协议,如TCP/IP协议、HTTP协议等。掌握网络编程的基本技术,能够编写网络应用程序。 2. 数据通信:学习数据通信的基本原理和技术,包括数据传输的方式、数据压缩和加密等。了解网络安全和数据保护的基本知识。 3. 程序设计:学习编程语言和开发工具,如Java、C++和Python等。掌握常用的编程技巧和方法,能够设计和实现复杂的网络应用程序。 4. Web开发:学习Web开发的基本知识和技术,包括HTML、CSS、JavaScript等。能够设计和实现交互式的Web应用程序。 5. 数据库技术:学习数据库的基本原理和技术,如SQL语言和数据库管理系统。能够设计和管理数据库,实现数据的存储和检索。 通过学习互联网络程序设计 uestc,可以掌握互联网应用开发的基本技能,具备设计和实现网络应用程序的能力。这对于目前互联网行业的人才需求来说是非常重要的,也为学生提供了广阔的就业和创业机会。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值