HDOJ 1003-Max Sum【DP】

Max Sum

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 197162    Accepted Submission(s): 46049


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 

Sample Input
  
  
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 

Sample Output
  
  
Case 1: 14 1 4 Case 2: 7 1 6
 

Author
Ignatius.L
解题思路:
dp用于储存累加的和,并和max的值比较如果dp都已经小于零则dp的下一位就不用累加前面的项从下一位开始。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int map[100000];
int dp[100000];
int main()
{
	int T;
	int ans=0;
	scanf("%d",&T);
	while(T--)
	{
		ans++;
		int N;
		int i,j;
		scanf("%d",&N);
		for(i=0;i<N;i++)
		{
			scanf("%d",&map[i]);
		}
		dp[0]=map[0];
		int start=0,endd=0,maxx=-1001;
		int frist=0,second=0;
		for(i=0;i<N;i++)
		{
			if(dp[i-1]>=0)
			{
				dp[i]=dp[i-1]+map[i];
				endd=i;
			}	
			else
			{
				dp[i]=map[i];
				start=endd=i;
			}
			if(maxx<=dp[i])
			{
				maxx=dp[i];
				frist=start;
				second=endd;
			}
		}
		printf("Case %d:\n",ans);
		printf("%d %d %d\n",maxx,frist+1,second+1);
		if(T!=0)
		{
			printf("\n");
		}
	} 	
	return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值