ZOJ Problem Set - 2773 Triangular Sums【公式】

ZOJ Problem Set - 2773
Triangular Sums

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The nth Triangular number, T(n) = 1 + ... + n, is the sum of the first n integers. It is the number of points in a triangular array with n points on side.

For example T(4):

   X
  X X
 X X X
X X X X

Write a program to compute the weighted sum of triangular numbers:

W(n) = SUM[k = 1..n; k*T(k+1)]

Input

The first line of input contains a single integer N, (1 <= N <= 1000) which is the number of datasets that follow.

Each dataset consists of a single line of input containing a single integer n, (1 <= n <= 300), which is the number of points on a side of the triangle.

Output

For each dataset, output on a single line the dataset number, (1 through N), a blank, the value of n for the dataset, a blank, and the weighted sum , W(n), of triangular numbers for n.

Sample Input

4
3
4
5
10

Sample Output

1 3 45
2 4 105
3 5 210
4 10 2145


Source: Greater New York Regional 2006
解题思路:
两个公式的递推。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
double oo(int i)
{
	return (i*i*i+3*i*i+2*i)/2;
}
int main()
{
	int T;
	int y=1;
	scanf("%d",&T);
	while(T--)
	{
		int n;
		scanf("%d",&n);
		printf("%d %d ",y++,n);
		int i,j;
		double ans=0;
		for(i=1;i<=n;i++)
		{
			ans+=oo(i);
		}
		printf("%.0lf\n",ans);
	}
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值