HDU 1709 (母函数)

The Balance
Time Limit: 1000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 7565 Accepted Submission(s): 3138

Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

Sample Input
3
1 2 4
3
9 2 1

Sample Output
0
2
4 5
题意:有一个天平 n 种砝码,问你(1 —> s)里面哪一个重量无法测量,s 是所有砝码总和, 注意天平两端都可以放砝码
题解:用母函数的方法,这次我的母函数有点改进,第一就是 j 的查询范围变小,第二就是由于天平两端都可以放,所以跳转后距离可以是 j + k 也可以是 j - k 取绝对值,这样就把所有范围都考虑完了

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
#define N 110
#define M 10010
#define CRL(a, b) memset(a, b, sizeof(a))

int n, sum, we[N], num1[M], num2[M];
int abss(int a)
{
    return a < 0 ? (-a) : a;
}
void getnum()
{
    CRL(num1, 0);
    CRL(num2, 0);
    num1[0] = 1;
    int flag = we[1];//定义 flag 为 j 的最大巡查范围 
    for(int i=1; i<=n; i++)
    {
        for(int j=0; j<=flag; j++)
        {
            for(int k=0; k+j<=sum && k<=we[i]; k+=we[i])
            {
                num2[k + j] += num1[j];
                int t = abss(j - k);
                num2[t] += num1[j];
            }
        }
        flag += we[i];
        for(int j=0; j<=flag; j++)
        {
            num1[j] = num2[j];
            num2[j] = 0;
        }
    }
}
int main()
{
    while(scanf("%d", &n) != EOF)
    {
        sum = 0;
        for(int i=1; i<=n; i++)
        {
            scanf("%d", &we[i]);
            sum += we[i];
        }
        getnum();
        int ans[M], flag = 0;
        for(int i=1; i<=sum; i++)
        {
            if(!num1[i])
            {
                ans[flag++] = i;
            }
        }
        if(!flag)
        {
            printf("0\n");
        }
        else
        {
            printf("%d\n", flag);
            for(int i=0; i<flag; i++)
            {
                printf("%d", ans[i]);
                if(i == flag-1)
                {
                    printf("\n");
                }
                else
                {
                    printf(" ");
                }
            }
        }
    }


    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值