hdoj-2199Can you solve this equation?【二分】

2 篇文章 0 订阅
      

Can you solve this equation?

Problem Description
Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.
 

Input
The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);
 

Output
For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.
 

Sample Input
  
  
2 100 -4
 

Sample Output
  
  
1.6152 No solution!
二分法(折半查找)
适用范围:当数据量很大适宜采用该方法。
做题时,碰到数据量大的时候,先想一想是不是可以用二分法
要求:采用二分法查找时,数据需是排好序的。(数据无序时,不能用!)
 
    这道题中 注意break ,continue ,return 的区别及作用
1. break语句通常用在循环语句和开关语句中,当break语句用于do-while、for、while循环语句中时,可使程序终止循环而执行循环后面的语句, 通常break语句总是与if语句联在一起,即满足条件时便跳出循环
break语句对if-else的条件语句不起作用。  在多层循环中, 一个break语句只向外跳一层
2. continue语句的作用是跳过循环本中剩余的语句而强行执行下一次循环。continue语句只用在for、while、do-while等循环体中,常与if条件语句一起使用,用来加速循环。
其实就是continue跳过一次循环以及后面的语句,进行下次循环
3. return语句是将函数的值返回主调函数
#include<stdio.h>
#include<math.h>	
double f(double x)
{
	return 8*pow(x,4)+7*pow(x,3)+2*pow(x,2)+3*x+6;     // return 将函数的值返回主调函数
}

int main()
{
	int t;
	double y,mid;
	double left,right;
	
	scanf("%d",&t);
	while(t--)
	{
		scanf("%lf",&y);
		left=1;
		right=100;
		if(y<f(1)||y>f(100))
		{
			printf("No solution!\n");
	    	continue;                   //如果没有continue   执行完if语句 	继续执行printf("%.4lf\n",left);
		}                               //例如:输入-4    则输出 printf("No solution!\n");和left(1.0000) 
		
		while(right-left>1e-10)         
    	{
			mid=(left+right)/2;
			if(f(mid)<y)
				left=mid;
			else
				right=mid;
		}  
	   		printf("%.4lf\n",left);
	}	
	return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值