hdoj-2199-Can you solve this equation? (二分法)

Can you solve this equation?

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 17   Accepted Submission(s) : 10
Font: Times New Roman | Verdana | Georgia
Font Size: ← →

Problem Description

Now,given the equation 8*x^4 + 7*x^3 + 2*x^2 + 3*x + 6 == Y,can you find its solution between 0 and 100;
Now please try your lucky.

Input

The first line of the input contains an integer T(1<=T<=100) which means the number of test cases. Then T lines follow, each line has a real number Y (fabs(Y) <= 1e10);

Output

For each test case, you should just output one real number(accurate up to 4 decimal places),which is the solution of the equation,or “No solution!”,if there is no solution for the equation between 0 and 100.

Sample Input

2
100
-4

Sample Output

1.6152
No solution!
#include<iostream>
#include<cmath>
using namespace std;
int main()
{
     int t,m,i,j;
    double x,y,s,n;
    cin>>t;
    while(t--)
    {
        cin>>n;
        if(n<6||n>807020306) cout<<"No solution!"<<endl;
        //cout<<pow(100,4)*8+7*pow(100,3)+2*pow(100,2)+3*100+6<<endl;
        else
        {
            x=0;y=100;s=50;
            while(fabs(8*s*s*s*s+7*s*s*s+2*s*s+3*s+6-n)>=0.00001)
            {
                
                if(8*s*s*s*s+7*s*s*s+2*s*s+3*s+6-n>0) y=s-1;
                else x=s+1;
                s=(x+y)/2;
                j=abs(8*s*s*s*s+7*s*s*s+2*s*s+3*s+6-n);
            }
            printf("%0.4lf\n",s);
        }
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值